Please help - problem uploading videos

I have uploaded my wmv files into the sansa media converter and when I go to play them on my e260, I get a message that says “Please use Sansa Media Converter to convert this photo file.” 

My first issue is that I’m not sure why the wmv file is being called a photo file, or why the problematic video in question ends up in a folder in the Photos section.  Shouldn’t it be in the video folder?

I’ve tried using various programs to convert the wmv file into different formats, and then using the sansa media converter, but I end up with the same result.  And it is a lot of trouble to go too.  

Any help would be greatly appreciated.  I’ve had a couple of friends help but we’re all wondering why this is happening and how to fix it.  I even went as far as to contact a video poster at to ask for advice - and while the advice given was amazing, hasn’t helped . . .

I have a long flight coming up which is why I really want to put video files on my player . . .

Meg - aka, Confused.