Please add defrag control in next version of cache software.

Hi, I would just like to request this feature because the process is kind of opaque right now, I’d rather have some control, the ability to exclude my data drives for instance, they have no reason to be defragged at some arbitrary threshold, I can’t tell if the software is waking the drives for no reason either.  I use something like ultradefrag already, so is it really necessary to force people onto automatic defrag?   Ultradefrag is free and defrags on boot so it can defrag more system files even, but I don’t know if its fighting express caches defrag or if express cache sorts things in some strange way.    I understand making it invisible makes it easy for non technical users, so their systems to not degrade in performance and generate unecessary support calls, but I think the option to disable this should be in the software, perhaps on an “advanced” panel…

1 Like

Also, the issue is in performance monitor is that I see expresscache.exe accessing multiple volumes at very slow rates,  like reading/writing 30,xxx-50,000 what I assume are bytes per second.  If thats the defrag process, its just a slow constant wearon those drives,

Ok identified the volume numbers using diskpart and the list volume command, it seems to be trying to defrag one of my data drives which has no applications, very slowly, please fix this, it shouldn’t be allowed to wear drives out slowly that have no need for defrag, no applications are on that drive at all.

Ok I’ve let it the system sit for the hours since my last post while afk, and its still reading and writing my data drives at the incredibly slow rate, the activity charts on the side of the resource monitor just show gapped peaks of activity, expresscache.exe is just keeping all my drives awake for no reason.   I expect some activity on c and f, since i was downloading something, but drives like E have no reason for being accessed.

here's the screenshot showing what expresscache.exe is doing.

Hey,

I totallly agree with wetnap!

Why is a defragger built-in to a caching software in the first place?

Please explain and thanks.

Compumind :slight_smile:

1 Like

Ok I tried turning off the service, then turning it back on, that worked for stopping the unecessary defrag for a bit,  but after a few hours I came back and it was back to accessing all volumes again, doing its slow slow defrag, wearing all my drives:(  it could be less than hours but i wasn’t around to check.

I might have to just turn off the service everytime I go afk it seems, a horrible chore:(

The bug related to the USB device eject error is NOT caused by defrag. There is NO Defrag activity running on the USB drive. We plan of relesing a fix for this bug in the next relese. 

Forum Admin

slotmonsta

Yes but what of the constant slow drive accesses on the other drives?  Is that related to that bug as well?  I’m at the point where I just turn off the service when I go afk because I know otherwise its going to access drives it has no business accessing.

Yes this is related to the bug we plan to fix in the next release. 

Forum Admin

slotmonsta

@ slotmonsta,

You mean there is a Bug for the Eject and another for the throughput (constant slow drive accesses) on atttached devices?

I’m a bit confused.

Please explain, thanks.

No, both issues are related to the same bug. Access to the USB device is locked open for the ExpressCache software. This prevents safe eject from occuring. As stated before we plan to fix this issue in the next release. 

Forum Admin

slotmonsta

Ok thanks for your help, good to know this is being addressed:)

Ok early times with the new 1.3.1 install, now the readycache process reads and writes to my drives at megabytes pers second while i’m doing nothing much, so I guess this is defrag?

Its still a bit annoying I can’t tell what its doing and can’t stop it. 

Ok its been many hours since it installed, and its back to the old behavior, its reading and writing drives at a certain amount of bytes a second, like 700bytes-40k bytes per second :frowning:

Whatever the usb thing was not enough to fix this issue.   I even did a full uninsatll and reinstall, with revo uninstaller, it was clean as it gets.

I guess i’m going to have to go back to stopping the service at night again.

I noticed the same disturbing i/o activity from the ExpressCache service.

I’m a retired Software Designer very familiar with control of Windows services using  the Service Control Manager, so its possible to use the Windows Service GUI or SC command to stop the ExpressCache service and set it into manual or disabled mode. You need to do this in Administrator mode. This should prevent the ExpressCache service from starting after a reboot. But without knowing exactly what the service does, it could cause problems - it doesn’t even contain a service description.

Adding extra i/o seems to be at odds with the performance benefits of hybrid SSD caching. There needs to be some detailed doc about exactly what this service does.

If it has a defrag function, then it may be stealhfully undoing what other defraggers do.

I can understand if it doing some i/o to the SSD cleaning up the cached LRU sectors…

If it’s a bug related to cache buffer flushing or USB eject problems, then it needs to be fixed ASAP.

Also, the next release should allow user selection of th drives to be cached.

I especially don’t like he idea of it caching removeable drives.

I personally would prefer that only the system HDD use the ReadyCache SSD.

Looks like stopping/disabling the ExpressCache service kills SSD caching too

until the next reboot ( must be in Automatic mode).

So leave the ExpressCache service in Automatic mode. 

What do you mean kill?

Did you try restarting the service?  I dunno.  According to the meter its still caching some after i restart it in the morning.

That being said the thing liked freaking out my raid controller setting off alarms so i had to put it back on my motherboards controller, where it likes to reset after it gets to 29gb or so:(

Bugs need to be sorted out, i’m passed my return date on this already so its a bit fustrating.