Playlists redirecting to the GoList

I have 28 playlists on my Sansa Clip.  When I choose some of them, instead of going to the songs in the playlist, it goes to the GoList.  This is very frustrating.  Seems to be related to their position in alphabetic order.  The 22nd, 25th, and 28th playlists all bounce to the GoList when I try to play them.  If I rename the exact same lists so they have a different position in the alphabet, they work fine, so I know it is not the lists themselves.

For the time being I am just copying the lists in those positions, ie ‘22ndcopy’, ‘25thcopy’, ‘28thcopy’ etc so I can play them.  Still though, it is weak sauce. 

BTW, this is on the Revision 1.0 hardware with the 1.30 firmware. 

What gives?

Bump!  Hello?

I can’t answer your question because I don’t make playlists :smileyvery-happy:

I think there was another post like this. Unless there’s something wrong with your Clip’s internal databases, this would be a very weird bug. I’ll try to see if I can reproduce it.

Yep, it’s verified. I’ve tried 100 playlists and the 22nd, 25th, 28th, 34th, 37th, and 40th are redirecting to the Go List. This is definitely a bug in the 01.01.30 firmware.

This was happening to me on 1.29 as well.

Yep!  I had this problem last winter, and just made blank playlists to get around it… until ‘bad’ playlists (ones that redirect to the GoList) started to change positions and the dummy ones worked while the good ones didn’t.  It seemed to change when I add certain songs. 

There was also a post on empty playlists caused by bad M3U tags in non-compatible character encoding (forget whether it’s UTF-8, or ANSI, or Unicode).  There’s a possiblity that it’s not empty, but rather redirecting to the GoList.  (kinda hard to notice) 

I’m not sure how the firmware is written, but it could be that some memory addresses were inadvertently shared with the playlist range.  

I think I’m going to get a Sansa Fuze while it’s on sale at BestBuy.  The 4GB model is  $49.99 (free shipping) today.  

EDIT: I confirmed that it is those same playlist numbers that are effected.  Seems like I forgot and put a playlist right in the middle of everything - oops.  Still, some songs just don’t show up even in good playlists.  

Message Edited by YueIBM on 11-29-2008 12:21 PM

Here’s the link from when I was trying to figure out the problem.

Seems like only certain M3U encodings trigger this, though.   Here’s the post on that. Seems like we could give UTF-8 a try.

Message Edited by YueIBM on 11-29-2008 12:12 PM

Message Edited by YueIBM on 11-29-2008 12:12 PM

My playlists are .PLA files.

I have 47 playlists on my Sansa Clip 4GB and I am having the same problem reported above.  I can also verify what “eliasf” posted earlier as the playlists that fall alphabetically in the 22, 25, 28, 34, 37 and 40th position are not accessible - selecting them results in the player going to the “GoList” instead.  If I delete a playlist, let’s say the 34th, then the new 34th (the one that was previously on the 35th position) redirects to the GoList as it is now the new 34th, so the problem is not with the playlists themselves but their relative positions as reported above.  I contacted Tech Service last night and they had not heard of this.  I asked for a Level 2 Tech (Anthony) and he also had not heard of this.  He emailed me Firmware 1.01.18 to revert back and test and with v.18 the playlists at 22, 25, 31 and 34 revert to the GoList - the others work ok.  I also tried Firmware 1.01.20 from the Sansa Forum:

but to no avail as it behaves just as v.18.  Since the older firmwares did not help much, I have reinstalled v.30A, formatted the Sansa, and reinstalled all my music using WMP11 but with the same results as before - playlists 22, 25, 28, 34, 37 and 40 still redirect to the GoList.  I added 4 new playlists thus changing some of the ones that fall in those positions and it is the alphabetical positions, not the playlists themselves, that create the problem.  I use WMP11 and my playlists are .WPL

I don’t know how many people have over 20 playlists but judging by the number of views on this post I suspect that there are many of us with this problem and no workaround.  We need help from the Firmware folks badly.  Many thanks.

Message Edited by elcpu on 01-08-2009 08:42 AM

They ought to give us the source code.  Lots of us know how to program.  Considering that we actually USE the device and CARE if it works properly, I’d be willing to bet my left arm that the user community could have the clip working perfectly much faster than whoever it is that Sansa pays to (poorly) write the firmware.

It’s not like playing .MP3s is some sort of trade secret; Sansa would not lose anything by giving out the source code.  They’d really just be serving the user community better by letting us fix the thing ourselves and add all the features we want that Sansa can’t be bothered to add themselves.

The clip works decent most of the time, but there are numerous errors and nothing is being done to fix them.  WE can do better.

Give us the source code!!! 

No,  but we’ve added it to the bug list.

The playlist re-direct to go list bug was fixed today. The code release with the fix will take a little time to pass through qualification, however. Look for either v01.01.32 or v02.01.32 firmware release. It should be available on the forum site and via the Sansa Updater in a couple of weeks. Thanks for pointing out the bug. Your comments brought it up enough in priority to get it fixed.

Please see my earlier post on this thread.  The Sansa Updater downloaded v01.01.32 into my clip today and the “Redirect to GoList” bug appears fixed.  On a quick look I checked all of my playlists and they seem to play fine.  Thanks for correcting the problem.