Playing Books Loaded from CDs

Short version: How do I load audio books from CDs into my Sansa Fuze, then play them back in order?

Long version: Once in a while, the Sansa Fuze plays more than the first second of a book loaded via Rhapsody, copied from (and converted from?) iTunes. (This is needed because Rhapsody doesn’t provide the ability to consolidate ‘tracks’ on one CD into one ‘song’.)

I’ve replicated iTunes’ Playlists in Rhapsody, then transferred them to the Fuze. They appear to have transferred Ok. If I reset the Fuze (by holding the side key more than ten seconds in the ‘up’ position), I can recover to the point of playing exactly one second of the beginning of the book. Selecting a different book doesn’t change what’s supposedly ‘playing’, but it doesn’t. Trying to ‘fast forward’ shows different parts of the book as ‘selected’ doesn’t turn on play back, and we’re still stuck at the original section.

Should I be using Media Player instead of Rhapsody for managing playlists? Should I not be trying to play playlists but something else? (I’ve tried playing from ‘Albums’ and ‘songs’ but there’s no change.)

Thanks in advance for any advice you can provide. I’m ready to return the Fuze to the vendor if this can’t be resolved, as listening to books from CDs is the only reason I bought it.

Lose the itubes & Crapsody! Rip your CD’s to .mp3 format with any one of a number of free programs. Edit the ID3 tags with MP3TAG (also free & easy) so that all the track #'s are two digits with a leading zero (01, 02, 03, etc.). Drag & drop these newly created files from your computer to your Fuze. Unplug, fire 'er up & enjoy.


Ah, Tapeworm, you’re a speed demon. If needed, here’s the process in a little more detail. 

Rip from CD to mp3,  edit (if necessary) the ID3 tags (which are what you’ll see displayed on the Fuze as Album, Artist, etc.) and drag-and-drop the folder onto the Fuze.

You like iTunes? Let’s use it, for the moment, just as a ripper: to make mp3s. 

Under Edit/Preferences/Advanced, under General, pick a new folder to import the books for this experiment. Call it whatever you want, like, just to be creative, Books. (After this experiment, don’t forget to change it back if you have another place where you were keeping your iTunes stuff.)

Still under Edit/Preferences/Advanced, go to Importing and Import Using: mp3 encoder. I use “Higher quality (192 kbps)” for music, but you might not need that for audiobooks.  Make sure “Automatically retrieve CD track names from Internet” is checked.

Save those changes. Now let’s rip: Insert the CD and import it. When it’s done, there should be a bright shiny new folder of mp3s in Books or whatever you called it. 

Now check the tags. Get the free and clever mp3tag and install it. Change one default setting. Under Tools/Options/Tags/Mpeg you want it to write ID3v2.3 ISO-8859-1, which is the Fuze’s favorite tag-flavored breakfast. Save that, never worry about it again.  

Go to your newly ripped folder in Books and right-click and you’ll see mp3tag in the menu. Choose it, and mp3tag will display the files in the folder. 

Now take a look. The left column, I hope, will have the files in the correct order, top to bottom.

See what you got as tags for Album, Artist, etc. That’s what you’ll see on the Fuze. Keep them or change them if you want–just highlight all the tracks, fill in the field, and Save (under file).

Now look at the Track column (you might have to scroll over) and it should have them listed 1/200 (or whatever), 2/200, etc. iTunes likes those slashes, but the Fuze would prefer them as just 01, 02, 03, and mp3tag can do that instantly. Highlight the list, go to Tools/Auto-Numbering Wizard and check the Leading zeros option. Click and watch all the track numbers get fixed. You’ve also changed all the tags to ID3v2.3 ISO-8859-1, which is good. Close mp3tag.

OK, now we’ve got a folder of mp3s with yummy tags for the Fuze. Put the Fuze in MSC mode (Settings/System Settings/USB mode/MSC) and connect it and open Computer or My Computer (Vista/XP). Make a new folder on the Fuze with a clever name like, oh, Books, or anything else you want. Drag your book into there. Disconnect, the Fuze will refresh and you should have a book ready to go.  

It took you longer to read this than the entire process will need.

If the experiment works, you can find your other ripped books, run mp3tag on them to get the Album, track numbers and ID3 version right, and drag them over too.  No Rhapsody, playlists or WMP necessary.

Message Edited by Black-Rectangle on 08-29-2009 10:51 AM

@black_rectangle wrote:

Ah, Tapeworm, you’re a speed demon.

I was answering the OP’s ‘short version’ question with a ‘short version’ answer. :stuck_out_tongue:

Thank you, Tapeworm and Black-Border. Since the initial post, I’ve discovered that the problem of getting only one second of playback was solved by running the original .m4a files through a separate (free) converter, creating .mp3 files. (m4a_converter.exe) Once loaded into the Fuze, they played nicely.

I’m not tied to iTunes per se. It’s ability to EASILY group tracks from one CD together just simplifies things. Many (35-40%?) of books on CD contain 99 tracks EACH. (Some employ using random words to ‘name’ each track, making direct copying & management more difficult, but I digress.)

Most books I’ve read average 7-9 CDs, and some more than 12. Even with numbering individual tracks with leading digits could mean managing over 1,000 tracks per book. Then there’s one folder per book, assuming leading numbers don’t duplicate those of the other CDs, in which case there would be one folder per CD.

I’ll try the suggested approaches as time permits. Thank you both again for your advice. User support like this is invaluable!!


No one seems to be calling that converter spyware or malware, so feel free, but iTunes itself has a Convert Selection to mp3 function. Look under Advanced. 

For the future, though,  change the iTunes default to write mp3s. They are much more universally accepted.