Phone and iPad crash with iXpand flash drive 3.

To start with, I thought this was a great piece of kit. Then it wouldn’t work with my iPhone XS, now it won’t work with my iPad either. I allow access to the app and it just comes straight out of the app to the home screen. Any suggestions?

1 Like

I am having the same problem. Been travelling through Europe, downloading photos onto ixpand flash drive, and problem became intermittent, and annoying. But now the flash drive is not detected at all on both iPhone and iPad. Have tried all the possible solutions provided and still not able to detect flash drive.

Please respond.

So with no response I started a chat session. As a traveller I have no access to a pc, the last chance too get my ixpand drive working as it should! So public libraries as was suggested by my SanDisk chat host as my last resort! 

Well the Seville Public libraries have firewalls and will not let you download!

Another problem was English only language and trying to use a Spanish keyboard. 

So still stuck with a product that doesn’t work!