Phantom file system?! WTF is going on!?

I bought a sandisk player abou 9 months ago. When I set it up I created a folder with my name on it and put all my stuff in that folder only. So I lost that one and bought a new one. This time I put my materials in the folders that ship with the unit. I did not create any new directories.

Well I plug the thing into my USB and when I click on the icon in windows explorer,  I can see the old file system! The folder with my name on it. All the same stuff that was in there and the files even play. I tried to delete the stuff but it says I don’t have permission…

Now you will say, oh he accidentally found the old one and he has that one plugged in. No! First of all the old one was 2GB the new one is 4GB. The old one was black, this one is blue. Furthermore, when I uinmplug the device from the USB, i can see teh new correct setup on teh device itself.

I have tried restarting both the computer and the device, but not resetting to factory settings.

Can someone tell me i’m not going crazy?

OK, you’re going crazy. :slight_smile:

This is only a guess, but the other possibility that occurs to me is that you are using music library software–like WIndows Media Player–that automatically syncs to your player, and when you connected the new one it saw a Sansa and sent over the stuff that it expected to see on the Sansa. And then, since Windows Media Player does invisible stuff with digital rights, it messed up your permissions.

Resetting to factory settings will not affect your added files–it will only make you choose language and region again and go back to default settings for the backlight, etc.

If you want to wipe the unit and start clean, go to Settings/System Settings/Format and format the unit.

Then, if you don’t want WIndows Media Player doing stuff automatically,  go into its settings and turn off anything related to Sync before you connect again.

Or, better, take control of the Sansa yourself–go to Settings/System Settings/USB Mode and change it to MSC. That will make it look like two USB flash drives to your computer, and you can drag and drop things onto the  Sansa or the memory card (which will appear as two separate drives).  Windows Media Player uses MTP mode, and if the Sansa is on Auto Detect it goes automatically to MTP mode if it sees Windows Media Player (10 or later) on your computer.

Your computer can only see one mode at a time, MTP or MSC. So make sure you transfer all your files in the same mode, whichever one you choose.

Your reply sounds reasonable, but if true it’s disapointing. Each USB drive device has a unique identification. You can see this if you decide a particular device should always mount with the same drive letter, as you might wish if have some sort of backup up scheme that would benefit from this.

If WPM or other software would blindly sync to other than a particular device that would be a problem for people using multiple devices. Personally I only use windows explorer, so am not familiar with the alternatives. Perhaps there is some sort of option that will sync to an existing library on the computer. This would be reasonable and take care of my concerns.

I do not nor have I ever used MTP (the WMP setting). I have always used MSC, the standard USB. Curiously, I tried plugging it into my laptop and I got the same effect. In any event. I have now  wiped it clean and have set it back up as MSC.

This will have to go into the books with the likes of the Loch Ness monster and Bigfoot.

The Clip gremlins at work again . . . .

BR: WMP will can sync to a DAP, even if it is seen only as a flash drive. Microsoft was smart enough to realize that there will be some MSC players out there.

Zulubanshee: I’m going to take a guess and say you might have a malware infection. I would consider doing a scan on your system, using multiple programs, if possible (you might not have to install additional software; there are plenty of boot disks available).

Also, see what happens when you connect the player to another computer. If the files from your previous player are visible from a second computer, perhaps they’ve been synced automagically. If this is the case, you might be able to perform a check disk to fix the “lack of permissions”.