out of box menu operation fault

I received two SanDisk Clip Jam players yesterday December 19, 2017, intended to be Christmas gifts, then tested, configured, and pre-loaded with songs for standalone local non-Internet use.  One of the players had a problem while the other one worked per the User Manual on the SanDisk customer service page.  Using the Clip Jam control button on the faulty unit was different than identical operations on the good unit.  In this case, the menu movement would not enter any item except top level.  Thus could not even get the cursor down into most Settings or Music files listed.  I was able to ascertain the actual hardware buttons were all functional.  Thus tried to use the 20 second press of the Power button to reset firmware but the issue remained.  I then looked at Info on the good unit that showed firmware at version 1.12 that is up to date so assumed the faulty unit probably had the same version.  

I then connected the player to USB cable to my laptop and followed the process on this support page to download the binary firmware file and then load and install it on the player that was simple and ran ok.  The player then worked correctly.  Thus an example of player firmware being up to date though memory corrupted.  Note the ways a player might exhibit incorrect operation with memory issues is considerable.