Only able to use 8gigs of my 32gig micro card

@bracarsha wrote:

When I try to add additional files, the message says. "the file xxxxx.xxx could not be copied. It may not exist or is in use by another program.

 

In “My Computer”, I can only see the maximum size of the internal and external Fuze drives. There are no "properties’ on a right click for the Fuze—only for actual recognized lettered drives.

There are (drive letters & properties) if you switch the player to MSC mode. More people have ‘weird’ or unexplained problems using MTP mode (or worse, Auto Defect) than I can shake a stick it.

Bracarsha wrote:

The only other thing I can think to tell you is that the card is a class 10.

That may have something to do with it. Class 10 cards are known to be problematic with Sansa players. Class 4 is ideal.

Hi Bracarsha, how did this work out for you? Did MSC mode as suggested fixed this? 

@kitscht wrote:

Hi Bracarsha, how did this work out for you? Did MSC mode as suggested fixed this? 

Given that I just replied to him 2 hours ago, you might want to give him a chance to try it and respond. :angry:

When are you going to start reading posts before replying?

What’s fixed is I’m no longer getting an error message when I transfer files.  BUT, with that said, I watch the files being transferred and check the folders on the Fuze and can see the files.  When the Fuze refreshes the new albums and songs do not appear.  Furthermore when I reconnect the Fuze to the computer, the new folders appear empty. 

Thinking there is a limit on the number of albums a folder will hold, I created a second folder for the same artist but added “2” to the folder name.  Again watched and checked the songs in each album on the Fuze.  Upon refreshing, I have the same problem.

When I check properties on a right click, I am seemingly utilizing 14 gigabytes.  (Twice what I had before)  BUT cannot see the songs on the Fuze or in Explorer.  “Info” on the Fuze coincides with what the computer says.  The total songs on the Fuze are 200 less than when I started!  But they seem to be on the micro card , but invisible judging from the filespace shown.

A question…when I connect the Fuze and the folder opens for the micro card, there is only one folder inside that window, and it is marked MUSIC.  The I open that folder and see three folders inside—one of which is again MUSIC and where my albums are.  Is this normal?

Am I losing visibility of the files on refresh because I’m using a class 10 card? 

Is Rockbox worth trying?  Thanks for bearing with me!

At this point, I would be tempted to format the player, reset to MSC mode and load it up again. Some of the confusion (and/or ‘missing’ files) could be that your computer can only see files loaded while it the same USB connectivity mode in which they were originally transferred in. In other words, files loaded while in MTP mode (or possibly Auto Detect which defaults to MTP mode) cannot be seen while in MSC mode, and vice-versa.

I’ve noticed too sometimes there are sometimes 2 Music folders, one inside the other. I simply move the files to the uppermost Music folder and delete the (sub) Music folder.

The Class 10 card could be causing some of the issues; they’ve been known to be problematic with Sansa Players, as they are designed for high speed and HD cameras, not mp3 players.

Another thing that could be causing some of the files to not show up )on the player) is the incorrect format of ID3 tag in the files. ID3 tags are what the player reads during the database refresh and then displays that information in your Artists, Albums, Genres, Songs, etc,. lists on the player’s screen, _ not _ the file names. If the player cannot read them, it simply does not display anything.

Tapeworm, you’ve covered a lot of territory!

The recognization problem is opposite of what you’re saying.  The older files which were put on in Auto Detect are the ones that are seen.  Some of the ones put on since I changed to MSC are the ones which are not seen.

(I honestly believe the card itself is limiting the number of songs!)

I’ve been using  Tag& Rename all along for the ID3 tags----But I do notice that the file and folder pictures do not appear on the new songs added to the player.  also in terms of the card…Many times I have to remove it for my Fuze to start because for some reason it doesn’t like it and freezes  I simply eject it and reinsert to force a refresh.  Then it recognizes it.

More evidence it doesn’t like the class 10 card?

Interestingly most if not all of the invisible songs had existing ID3 tags, which I only added pictures to. 

I think my next step is to either get a class 4 card, or should I try Rockbox first?

Thanks again!

P.S.  I’ve been using the player for the last 3 hrs, and it is as dependable as ever.

@bracarsha wrote:
 

I’ve been using  Tag& Rename all along for the ID3 tags----But I do notice that the file and folder pictures do not appear on the new songs added to the player. 

Many people have reported issues with Tag & Rename. If you’re using Windows, MP3Tag is the resounding and unchallenged favorite tag-editing software.

@bracarsha wrote:

also in terms of the card…Many times I have to remove it for my Fuze to start because for some reason it doesn’t like it and freezes  I simply eject it and reinsert to force a refresh.  Then it recognizes it.

 

More evidence it doesn’t like the class 10 card?

 

Yep.

Bracarsha wrote:

 

 

Interestingly most if not all of the invisible songs had existing ID3 tags, which I only added pictures to. 

 

 

We’ve heard problems where tags could not be read if the tag had embedded album art and the image was too big. 500 x 500 pixels and under and 100kb or less in size is the maximum you want to go with.

Or you don’t have to embed the image in the tag at all. One .jpg (yes, it has to be this format) in the folder named “album art.jpg” or “folder.jpg” (without quotes) with the music will be dispalyed on the screen for all the files in that folder. This works well if you have your music organized by album, but not if you have a mix of different artists and/or albums in the same folder. For that, you’ll want to embed each ID3 tag.

@bracarsha wrote:

 

 

I think my next step is to either get a class 4 card, or should I try Rockbox first?

Thanks again!

 

 

There’s nothing worng with Rockbox, some people like it. But if you prefer the simplicity of the Fuze and its original firmware and UI I would try a Class 4 card. You can always try Rockbox later.

I plead guilty!!

Although most of my art is 200x200 (or so)…once in awhile I get lazy, and let it go when it’s bigger!!!

I will switch to MP3Tag.  I do like the original Fuze firmware.  I will switch to a class 4 card and get back to you!

Thank you so very much Tapeworm!

I got a Sandisk 16GB Class 4 card tonight, formatted it fat32, and started putting music on it.

Once more after loading around 8GB, I received the message that the disk was full.

 

Evidently I need to redo everything using MP3Tag, and be careful about

the size of graphics. 

Tapeworm, since I have each album in its own folder should I just use a graphic

for the album and not use any for the individual files?

Is it possible that the album AND file pictures are looked at as files by the Fuze?

(almost all of the songs have both file and folder pictures)

Why else would I reach the same limit on 16gb and 32gb cards?

I don’t think the cards are full but rather the Fuze can’t accept any more data.

Maybe that translates into a problem with Tag & Rename?

The error is in windows right when you copy the files? If so the tags don’t matter yet. You mentioned files not appearing after the card is removed. Maybe a fake card? Hopefully you bought these from a legit retailer.

I don’t think it is a windows error at all.

The card in my Fuze is acting as though it is full.

The files with the questionable tags produced by Tag&Rename are on the card.

Install mp3tag and allow it to add to context menus, an option during install. Set Write to ID3v2.3 ISO-8859-1. 

The Fuze does NOT read ID3v2.1 tags, which may have been coming out of Tag & Rename. It also does not read ID3v2.4 tags.

Simply by opening a folder/album (right-click for the context menu), highlighting all files and Save (under files) you can fix the version.

You can also very efficiently dump the album art. Highlight all the files and if the album cover shows up in the Mp3tag window, go to View, Extended Tags. Hit the little floppy icon to save the art as folder.FILETYPE. Hit the X to remove the imbedded art.

If you’re lucky, the art you saved will be folder.jpg and you’re done.

If the art was a .png or .bmp instead, it will save as folder.png or folder.bmp. You can open that in Windows Paint, resize it if it’s too big and save it as folder.jpg. You might want to dump the bigger .png or .bmp file, or make sure that when you transfer the album that you delete folder.png from the Fuze.  

There is an upper limit on the size of the database that displays songs on the Fuze. Longer filenames and more tag into will fill it up faster, and you may well hit that limit before you fill a 32GB card.

Stupendous!

THANK YOU!

saratoga makes a good point here. Many (if not all) of the counterfeit 32GB cards use an actual 8GB card that is hacked to appear on the surface as 32GB . . . until you go to fill it up or use that extra space.

You can test the card with h2testw (free). It will tell you if you have a hacked card or if there is some defect.

Thanks for the info, Black-Rectangle.

I have followed it precisely, but I am not getting very good results.

I can see all the pictures from within Mp3tag, but only a small percentage of them show on the Fuze.

I’ve resized them and resaved them, but most of them still do not show in the Fuze.

I’ve worked with files directly on the Fuze as well as those on my computer, and then transferred those.

I can see the indication of  the tag being ID3v2.3, but no indication of ISO-8859-1in the listing of the tag info.

(I do have that indicated under “MPEG” when I go to “Tools”–“Options”

I’ve deleted the photos, resized them and see that the new size is being used.

Some of the photos that do show were done in Tag & Rename.

I know I must be doing something wrong but what?

I still have 250 mb left on the card.

I’m using only jpg files, and the name folder.jpg is inside the folder being worked with.

I feel I’m really familiar with the program now, but something just isn’t right.

Can you straighten me out?

Don’t know what to tell you. If folder.jpg is in the same folder as the rest of the files from the album it should show with all the songs on the album. 

ISO-8859-1 doesn’t show, that doesn’t really matter if you can see Album, Artist, etc.  What the ISO means is Windows encoding for characters (as opposed to the UTF that Apple uses). 

All I can suggest is that if you are you using mp3tag, do it on your computer, delete the album folder from the Fuze, and transfer the version you have fixed with mp3tag over again. When you disconnect it should refresh the database with those nice new tags.

Have you tried h2testw to make sure the card isn’t counterfeit?

I did the changes on the computer at first, deleted the album from the Fuze, and transferred the corrected album (I thought)

to the Fuze.  It was only after that failed to work a few times that I tried to do it directly on the Fuze.

I resized the pictures to 200x200, and those are the ones that show.

When I reopen the albums with mp3tag, every album picture as well as all the tags are visible.

(It made me realize there were many comments that needed to be deleted)

I currently have a 16gb card in the Fuze which I have now filled except for about 250gb.

With the new card, refresh is quicker, and I haven’t had a freeze problem which necessitated removing the card to force a refresh.

h2testw is telling me that the 32gb card I was originally using is, in fact, defective.

Sometimes the Fuze only refreshes its database incrementally–that is, if it sees the same album it doesn’t bother to re-read the tags.

Seems like you’re tooling along fine, but if you want to do a complete database refresh, here’s how:

Make sure you are in  Settings/System Settings/USB Mode/MSC. Write down the one you were using before if you had to change it. (There are only two settings, MTP and MSC–Auto Detect will choose MTP if it finds Windows Media Player 10 or above on your computer.) Connect and explore the Fuze driveletter in My Computer. MTABLE.SYS is the database file, the index built from the tags. Delete that, disconnect and it will build a whole new MTABLE.SYS with the newest tags in the Fuze. 

Files can be transferred by either USB Mode, all visible on the Fuze. BUT  the computer can only see files transferred in one mode at a time. When you switch mode, files transferred in the other mode are invisible from the computer. So switch the USB Mode back to what you were using before.  

It’s still generally better to fix tags on the computer–that way you have the permanent good copy on your computer to transfer whenever you need to.

OH YES!!!

The great majority of my album pictures are showing now!  That refresh did it!  THANK YOU Black-Rectangle!

Just browsing through the albums quickly, it seems as though folders with numerous albums within, are the ones not showing now.  Is there a limit on the number of sub folders/albums you can have inside a single artist’s main folder?