OneClickDigital Media Manager worked once, now refuses to transfer books.

I bought my sansa clip to use to listen to library books.  My library uses OneClickDigital and I downloaded the OneClickDigital Media Manager to manage my library audio books.  The first one I tried downloaded and transfered with no problem.  Worked great.  When I was done with that book I wanted to listen to another.  Whenever I try I get the error message:

“An error occurred with this operation, please check your device’s disk space and connection to the computer, and retry this transfer.   You are currently set to transfer to Sansa Clip+ 4GB.  You may uncheck the check box on the main screen to re-enable device detection.”

There is plenty of space.  The only thing I have ever transfered to it is the first book which has long since expired and been deleted.  I assume the connection is okay since my PC (Vista) recognizes it.

I have no clue what to try to get this to work.

Ideas?

Thanks,

KarinSue

Personally, I’m not familiar with that system/software.  You might try telephoning SanDisk at its toll-free Customer Support number, if no one else has an answer here, and see if SanDisk has a “cheatsheet” for the use of the software with the Clip.

To contact SanDisk:

http://www.sandisk.com/about-sandisk/contact-us/

Did you try un-checking the box as instructed? I’d guess that OneClick registers each device you connect in order to recognize it, and somehow it has messed up its connection with the Sansa.  Maybe if you disconnect,  un-check and reconnect it can rebuild the connection.

Also, on the Clip, try Settings/System Settings/USB Mode and made it MTP (if you’ve never reset it then it may be on Auto-Detect). MTP is for digital-rights files like library audiobooks. 

There’s also the nuclear option. Make sure you have copies of all the content (music, books, photos, etc.) you have added to the Clip, and then go to Settings/System Settings and Format it. That would clear away a corrupted file if that’s what’s creating the problem. Of course, it clears off everything else too, which you’d have to reload. 

Or even telephone SanDisk for support, before going “nuclear” and deleting files–SanDisk may already have worked this out . . . .

try going to the preferences tab and check the settings. I changed the time to 20 seconds and it works better.

Thanks for the suggestion.  I tried changing the seconds (from 7 to 20 and to 40) in the preferences and it did not help.

Are you using OneClick on Windows or Mac? Mac might have its defaults set for those dopI players. 

Also, look at some OneClick stuff:

http://www.kslib.info/digitalbooks/oneclick/ocanswers.html

<!-- [if gte mso 10]&gt;

&lt;style&gt;
/* Style Definitions */
table.MsoNormalTable
{mso-style-name:&quot;Table Normal&quot;;
mso-tstyle-rowband-size:0;
mso-tstyle-colband-size:0;
mso-style-noshow:yes;
mso-style-parent:&quot;&quot;;
mso-padding-alt:0in 5.4pt 0in 5.4pt;
mso-para-margin:0in;
mso-para-margin-bottom:.0001pt;
mso-pagination:widow-orphan;
font-size:10.0pt;
font-family:&quot;Times New Roman&quot;;
mso-ansi-language:#0400;
mso-fareast-language:#0400;
mso-bidi-language:#0400;}
&lt;/style&gt;
&lt;![endif] -->

OneClickdigital Support gave me a solution.

Hello,

Thank you for contacting OneClickdigital Support. You may require a Windows Media Player security upgrade, which you can receive by downloading a protected title as a .zip file and playing it with the Windows Media Player. Windows Media Player will attempt to play the file, realize it requires an upgrade and prompt you to download it.

In order to do so, please change your settings under the My Account / Preferences tab of the OneClickdigital website to

Use OneClickdigital Media Manager as my default player: No

1.) Once you have changed your preferences, go to your My Collections tab and click Download Now next to a title you are unable to download in the Media Manager. You will be prompted to download the .zip file containing the title.

2.) When the file is downloaded, open it and then open one of the tracks inside in Windows Media Player.

3.) If a Windows Media Player security upgrade is needed, you will be prompted to download it.

a.) You may also be prompted for a Digital Rights Management Acquisition login, if so please enter your username and password.

4.) When the title plays in Windows Media Player, close Windows Media Player and try your title again in the OneClickdigital media Manager.

**Please remember to change your OneClickdigital Media Manager Preference back to “Yes” once you have checked for the upgrade.

Again, we apologize for the inconvenience. Please let us know if you experience further difficulty or have any questions

Thank you,

OneClickdigital Support Team

I followed the instructions.  I was not prompted to download a security upgrade but I was prompted to log in with my library info.  Once having success in WMP I switched back to OneClickdigital Media Manager and was able to download and transfer the book to my clip with no problems.

Thanks for everyone’s input.

(I am using a Windows Vista PC)

Karin