On x64 XP no id3 tags when transfering songs

I have recently purchased a new computer which is running XP x64.  Now whenever I transfer any mp3s to my Sansa Clip the id3 tags seem to be gone or not working.  All the files come up as Unknown artist Unknown Album.  If I use my old laptop to transfer the same files then it comes up correctly on the Clip.   I also noticed on exporer on the new machine that the properties page for the mp3 files does not show the id3 info but if I open the file in winamp and use winamp to view the id3 then it shows up fine.  I did some googling and apparently the explorer thing is a known bug in x64 xp

http://en.wikipedia.org/wiki/Windows_XP_Professional_x64_Edition#Windows_XP_Professional_x64_Edition “ID3 tag information from music files are not viewable in the Windows Explorer.”

Why would that affect the files that I transfer onto the Clip ?  How can I get my files onto it and have it show the proper info ?   

Have you tried to copy your music with some commander (f. e. Total Commander) ?

I think it helps

I just tried total commander and the sansa clip does not come up as a drive in it

Please try it in MSC mode. On the Clip, go to Settings>USBMode>  MSC . I suspect that should work.

Another trick is to try WMP11 to transfer them.

  

Let us know. 

Message Edited by sansafix on 06-04-2008 03:31 PM

That appears to work, thanks