odd files showing up in music folder using Mac and Quicktime mp3's

    I noticed an odd thing when I was loading some mp3 files from my Mac to the Clip.    Those mp3 files that had a Quicktime icon on the Mac  seemed to add an extra file in the Clip Music folder.   The Clip seems to think the extra file is music, but it is very short and only gives a clicking sound when it is played.

Does anyone know what might be going on here and how to stop this problem?    Can I do something to the files on the Mac so they won’t add these extra files to the Clip?

Could you give more information about these extra files?

For each Quicktime mp3 file that is transferred to the Clip, there will appear two files in the Clip’s Music folder.   One file is the normal mp3 audio file with the intended song.   The extra file that appears is about 4 or so seconds long.   There is no apparent audio content in the file, but it does seem to make a short “click” sound when played.    That’s about all I can tell about the extra file.   I am presuming that this file has something to do with additional information in the Quicktime file compared to a normal mp3 file.   Does that help?

can you give example??   of what the hell is a quicktime mp3?

rvmeush wrote:

For each Quicktime mp3 file that is transferred to the Clip, there will appear two files in the Clip’s Music folder.   One file is the normal mp3 audio file with the intended song.   The extra file that appears is about 4 or so seconds long.   There is no apparent audio content in the file, but it does seem to make a short “click” sound when played.    That’s about all I can tell about the extra file.   I am presuming that this file has something to do with additional information in the Quicktime file compared to a normal mp3 file.   Does that help?

By the way, an MP3 file is just an audio file.  You probably describe it as a “Quicktime mp3 file” because your PC is set up to play MP3 files using the Quicktime application.

 

So the extra file must also be an MP3 file (have a “.mp3” extension)?  Or is it something else?

 

How do you transfer your MP3s to your Clip?  Drag-and-drop, or something else?

Message Edited by PromisedPlanet on 11-30-2007 09:15 AM

Message Edited by PromisedPlanet on 11-30-2007 09:16 AM

qt and all apple is predatory.  i would reassign default player .  see what happens

I have accumulated numerous mp3 files on my Mac.   For some reason, some of these files appear with an iTunes icon and some of these files appear with a Quicktime icon.   The icon generally gives an indication of what application will be lauched to play the mp3.   In all cases I use “drag and drop” to get the files into the Clip Music folder.    When I drag and drop mp3 files with the Quicktime icon, I get the extra file in the Clip song list.   When I drag and drop the files with the iTunes icon I only get the intended music file.

That’s what I’m observing.   I have not yet run an experiment to change the lauch application on a Quicktime mp3 file to be iTunes, and then do the drag and drop to the Clip to see if that fixes the extra file problem.

Does this help explaining what I’m observing?

seriously, there is no good reason to have qt or itunes as default for mp3… the more you say, the more im sure … re assign your default app for mp3

On a Mac, the default player for mp3 files IS iTunes.   While I could probably find another mp3 player, it isn’t the iTunes mp3 files that are causing problems.

I can probably find a workaround to the Quicktime mp3 problem, but I was trying to understand what was going on to cause this problem.

So, does anyone know what there is about Macintosh Quicktime mp3 files that might lead to the extra song files appearing in the Clip Music directory?

I’m baffled.  In MSC mode, copying one file (MP3 or whatever) from your computer’s hard drive to the Clip’s memory shouldn’t copy the file AND create a new file.  It should behave in the same manner as if you copied the file to another hard drive, or another directory.  There must be something else going on.

Can you tell me what firmware you have on your player?  Is it the current firmware 1.01.17?  That would help to determine the root cause and to troubleshoot it.  I played around with my Sansa Clip with version 1.01.17 and did not see your issue but I would love to know more about these errors to avoid it.

I am using the latest firmware version - 01.01.17A.  

I did some investigation of the encoding used on several of the mp3 files that I am using.   The iTunes files begin with an “ID3” tag - indicating that they are mp3 files.   The Quicktime mp3 files do not start with an “ID3” tag, and I suspect it is this difference that is causing the Clip to interpret the file as  two songs - one which is the normal music file, and another file which is the extra file I am seeing in the Clip song list.  

If anyone would like, I could send you a copy of a Quicktime file that is causing the problem to see if you get the same result.

Are there any readable characters at the tops of the files you are describing as “Quicktime MP3”?   If so, what are they?

I did some further checking on the files in the Clip.     I noticed that there was one song in the Clip song list that did not appear as a file when I mounted the Clip as a drive on my computer.   After fiddling around for a while, I decided to delete all the songs on the Clip and start loading them back one at a time.   The first song I copied to the Clip appeared to be an iTunes mp3 and had the ID3 tag, but when I listed the songs in the Clip there were two files shown - one regular music file and the other was the extra file.   Following are some of the first bytes from the file shown in ASCII and hex.   The ASCII listing doesn’t diplay all of the non-printable charaters.

ID3

for some reason the text doesn’t show up when I paste it into the message editing window - I’m stumped why this is happening.  Any ideas?

“I did some further checking on the files in the Clip.     I noticed that there was one song in the Clip song list that did not appear as a file when I mounted the Clip as a drive on my computer.”

 

Possibly a file synced in MTP mode, but it’s difficult to tell.

 

“After fiddling around for a while, I decided to delete all the songs on the Clip and start loading them back one at a time.”

 

To start from a totally clean slate, the best thing would probably be to format the flash, rather than deleting the songs.

 

 "The first song I copied to the Clip appeared to be an iTunes mp3 and had the ID3 tag, but when I listed the songs in the Clip there were two files shown - one regular music file and the other was the extra file.   Following are some of the first bytes from the file shown in ASCII and hex.   The ASCII listing doesn’t diplay all of the non-printable charaters.

ID3"

 

A typical MP3 file will have “ID3” at the beginning, followed by non-printable characters.  Were there any bytes before the “ID3”?

rvmeush wrote:

for some reason the text doesn’t show up when I paste it into the message editing window - I’m stumped why this is happening.  Any ideas?

Well, I saw the “ID3”.  If there were any non-printable characters before or after the “ID3” that you attempted to paste, I wouldn’t be surprised to see them tossed out by the editor.

I have had the same problem, it made duplicate files in the Music list for 4 out of 12 songs of an album.  They were all tagged the same so I’m not sure why it would single those ones out.  The duplicates made a small chirp sound when played, and the other copy worked fine.  So any ideas out there?  I am also using a Mac but all of my mp3’s are associated w/ ITunes.  I was able to delete these from out of the song list all except for the 1st one for some reason.  But if I had to do this for an entire 2 gigs of music, it would be a huuuge pain.

I have done some further investigating on the “extra files” problem.  The issue has to do with the way that Mac OS X  deals with its own special types of files when they are written to a flat file system like the one used on the Sansa disk.   Apple files sometimes include several parts - the normal data part, and another part called a resource file.   When Mac files that include a resource component are written to the FAT file system on the Clip, a special resource file is created in addition to the normal data file.   The resource files all begin with “._” followed by the file name of the data part.  Apparently there is no good way to prevent the Mac OS from doing this, so the easiest way to deal with the problem is to delete the files after they are created.

I found a simple program that can be used to delete these extra files - it is called WinFSCleanser.  You specify the path to the files you want to delete and tell it what kinds of files to process (e.g. mp3, gif, jpg, etc.).   The program works pretty well.

It occured to me that a simple shell script would be able to handle the deletion of this files.  A friend of mine at work helped develop this simple script that seems to work:    

find  /Volumes/Sansa*Clip/Music  -name  “._*”  -maxdepth 1 -exec rm -f  {} ;

Using this script from the Terminal window on a Mac should get rid of the offending files.   I’m working on converting this script into an executable program that can be run like other Mac programs.   I’ll post further info when I get it working.

I also requested that Sansa technical support include in their firmware an option to automatically delete Music files that begin with “._”     Since Sansa doesn’t really provide Mac support it seems like the least they could do to make life for Mac users a bit easier when using the Clip.   I suggest that other Mac users also request that a feature like this be included.

I found another program that allows copying of files to the Clip without the extra “._” files.  The program is called  KopyMac and it handles the copying and deleting operations together.  

KopyMac can be found at   http://www.tcsn.net/mont/Digitol_Disturbance/Digitol_Disturbance.html