Obstacle with Sansa Express 2GB

I just purchased a new (not refurb) Express 2GB.  Upon opening it, I plugged it in and my computer (Vista SP1 32 bit) recognized it.  I downloaded the firmware upgrade software and ran it.  However, after it was done, I immediately had a problem with the device although I haven’t even put any files on it yet.

When I turn the device on, it shows “Building Database” and the progress bar under it fills, over and over.  It never gets past “Building Database.”  After about 15 seconds of “Building Database,” the screen goes blank.  At first I was worried that the batteries were just dying, but I left the device plugged into a USB port over night and it said “charged” several hours later when I woke up.  When I try turning it on, I still get the same problem: “Building Database” for 15 seconds or so and then the screen goes blank.

I’ve tried plugging the device back into my computer, but my computer no longer recognizes it as a drive, and the firmware updater won’t run because it says the device has to be in MSC mode to update.  However, I can’t change to MSC mode because I can’t even get into the menu.

I’ve tried doing a reset by holding down (+) and Select, but that just makes the screen go blank and doesn’t effect the problem.  I’ve also tried holding down (-) while it’s connected to the computer, but that hasn’t done anything.

Any help please?