Not working????

I played 4 consecutive 2 and half minute AVI vids. Now it won’t work

The whole unit is so hot in my hand? Battery okay? Do I have to recharge

already??

@luv_the_sansa wrote:

I played 4 consecutive 2 and half minute AVI vids. Now it won’t work

The whole unit is so hot in my hand? Battery okay? Do I have to recharge

already??

On a full charge you should get around 4 to 5 hours on a full charge.      How hot it hot?    The Fuze may warm while watching video, it uses up more power.    But shouldn’t be burning hot.   Put it on the charger and keep an eye on it.   Check see if it is taking a charge.   Check that you can communicate to it via the computer.   Disconnect if it gets abnormally hot, and call Sansa Support.

Let us know if its working,  Cheers.

Did you hold it the whole time? This could cause the heat. If not then that heat is a sign of a BIG PROBLEM. If you can RETURN IT or Call Tech support.

@niko_sama wrote:


@luv_the_sansa wrote:

I played 4 consecutive 2 and half minute AVI vids. Now it won’t work

The whole unit is so hot in my hand? Battery okay? Do I have to recharge

already??


 

On a full charge you should get around 4 to 5 hours on a full charge.      How hot it hot?    The Fuze may warm while watching video, it uses up more power.    But shouldn’t be burning hot.   Put it on the charger and keep an eye on it.   Check see if it is taking a charge.   Check that you can communicate to it via the computer.   Disconnect if it gets abnormally hot, and call Sansa Support.

 

Let us know if its working,  Cheers.

 

Sorta. But only the bottom of the player will get warm as the battery works. If its the whole player something is wrong.