Not compatible with USB 1.0??

    I just bought a sansa clip from newegg…now that newegg site says the requirements are just USB port, so i assumed I could use it. 

so after getting my Sansa Clip today and plugging it in, I see a popup in lower right side toolbar which says something like " High speed USB plugged into non high speed USb"  So i says ok, I’ve been able to use USB 2.0 devices before with my computer; it will just transfer at slower 1.0 speeds. no problem.

however I do not even see a USB device for the Sansa clip in my computer.  There is no detection of it.

What is the problem? Do i really need USB 2.0 or I wont be able to use my Sansa Clip?

Actually the minimum requirements of the device is a usb 2.0 but if you have usb 1.0 and if you can transfer songs on the device it means that you can use your computer the only difference is the transfer rate… If your going to transfer songs on the device using usb 2.0 it will transfer to the device faster compare to a usb 1.0… If you can wait transferring songs on the device on a slow transfer rate you can use the 1.0 but if you are not satisfy with the transfer rate you need to use 2.0

yes i understand usb 2.0 is supposed to be backwards compatible. hence y i said i have used usb 2.0 devices before abd that the transsfer rate falls back tp usb 1.0 speeds.

my problem is sansa clip is not appearing as a removable storage device…my comp does recognize that there is a high speed connection and nothing more; the sansa does not appear in My Computer.

Do you have windows media player 10 or higher installed?  I have a desktop that’s 7+ years old that’ll charge my Clip, but it doesn’t recognize it.  I think it might be because I have an ancient version of wmp installed on it.

Try connecting it via MSC mode.  This will help to determine whether the problem is with your MTP installation, or possibly the USB connection.

I tried mine on a system with USB 1.0 ports, and it worked fine. It did give the low speed connection warning, but it still worked OK.

The Clip requires a usb connection - 2.0 is recommended – and Windows XP or Vista with Media Player 10 or 11, in order to work properly as an MTP device.

Earlier versions of WMP may work, or not. If you don’t get a connection, you can try upgrading Windows Media Player.

If your OS is older than XP, you may need drivers or driver updates in order to connect to the clip. It won’t show as an MTP device.

If the device is connecting, you should see some USB device in hardware manager. XP handles the drivers automatically, if everything is normal.

 putamaricon1, as mentioned there are two things likely to help:

  1. Connect in MSC, see explanation in the first post here.
    2) Update Windows Media Player. Then your Clip should be recognized simply plugging it in.

If you want to know more about USB speeds and technology, check out this website:

USB 1.0/1.1 = 1.5 mbps [Low-Speed USB]

USB 1.0/1.1 = 12mbps [Full-Speed USB]

USB 2.0 = 480mbps [Hi-Speed USB]

USB 3.0 = 4.8gbps [Super-Speed USB] * future specification, due out somewhere between late 2008 and 2010.

It should be noted that USB 2.0 @ 480mbps is the theoretical maximum speed, but you will never attain those speeds with most devices.  A more realistic throughput rate would be 200-400mbps.  Transfer speeds are also quite dependant on the USB device’s own read and write rates which can be much slower than 480mbps.

Flash memory reads and writes very fast within itself (internally) but external transfers slow it down considerable.

As another note, FireWire/iLink/IEEE1394a is much faster than USB 2.0 in actual world usage, even though 1394a is rated at 400mbps, it really does get 400mbps, where as USB 2.0 480mbps never reaches 400 or 480mbps.  There is also a IEEE1394b specification which is 800mbps.  You’ll find these ports in some laptops and on all Macintosh products except the MacBook Air.