No Sound out of One Ear (Broken headphone Jack)

Hi thanks for this, my headphone jack is now fixed! I had the exact same problem but you don’t actually need to get the soldering iron out (well not in my case anyway). When the headphone wasn’t working I noticed if you pushed the connector on the headphones down it would play fine out of both, only problem is you have to hold it there.

I opened mine up following the instructions you gave but instead of taking the ram chip off and soldering, I placed a tiny bit of blu tac on top of the phone jack, then stuck a small bit of dense foam on top. The reasoning behind this is that the case will push down on this, thus having the same effect as pushing down on the headphone connector. This brings the third connection point back in contact and it plays fine.

This isn’t as good a fix as a solder job but it is certainly worth trying if you are not confident with a solder and don’t want to risk anything, afterall if this doesn’t work (It worked fine on mine but I can’t guarantee it will in every case) you can always still solder.

No SPAM in your ‘sig’ please!

@autobahnsho wrote:

Maybe take it to a TV or computer repair shop and ask if they do small soldering- if so, they should be able to fix it in just a couple minutes…

Thanks for the repair instructions and links, Will, but I don’t see these fingers making it happen!  There’s not much in the way of TV repair here these days, but there’s a computer repair shop or two around.  I think I’ll follow that up.

Steve

Great descriptions!  I also had the same problem with the BIG blob of solder on a refurb e250.  I dissected things a bit and came up with a way to fix mine.  First, the solder blob was a repair that connected the back headphone jack contact to a resistor (the thing you thought might be a transistor is actually a resistor of about 0.2 ohms).  Evidently the original circuit board trace broke between the headphone contact and the resistor.   On my Sansa, the solder blob had acturaly ripped loose the end of the resistor and destroyed it (the headphone jack had torque it).   I got the jack fully working again by just removing the resistor (use de-soldering braid) and adding a jumper wire from the rear headphone jack contact and the input side of the resistor thahat had been pulled.  I uploaded a few pictures to detail it a little…

 http://picasaweb.google.com/stickery/SansaHeadphoneJackRepair#5326628224637090706

 http://picasaweb.google.com/stickery/SansaHeadphoneJackRepair#5326624652983213314

http://picasaweb.google.com/stickery/SansaHeadphoneJackRepair#5326624667147332002

Not sure what value the resistor was adding… but since mine was trashed figure what the heck… nothing to lose.  Sound is fine out both ears - no static.

I suppose if your resistoris not trashed you can solder to the output end of it and retain its function…  the space is way tight though and soldering a little difficult…  mine solderiing was ugly but fully functional.

I was able to simplify my life a little as well by lifting the plastic headphone jack housing off the front metal leads (they were soldered to board).  the back headphone lead had broken from the board completely.  With it off, I then pulled that back lead out of the plastic housing of the headphone jack.  I was then able to do my soldering with the plastic out of the way.   I soldered the jumper wire to the board at the resistor contact and the other end to the rear headphone jack metal contact… pushed the lead back into the plastic housing and then pushed the housing back onto the two front leads…

Sorry, I did not get a few more in progress pictures…  but was really making it up as I went along and did not think it would work…  :slight_smile:

Hmm- I have 2 Sansas that need this treatment.  :dizzy_face: The resistor must be there for SOME kind of reason though?

-Is the volume any louder on one side?

-Does it cut out if you crank the volume up??

@autobahnsho wrote:

Hmm- I have 2 Sansas that need this treatment.  :dizzy_face: The resistor must be there for SOME kind of reason though?

 

-Is the volume any louder on one side?

-Does it cut out if you crank the volume up??

 

 

I too expected to hear a difference in the earphones… but can’t.  It cranks up without cutting out and the sound seems balanced side to side.  I also expected static or something… but again sounds fine.  And yes one would expect the resistor does something… maybe some slight change in frequency or something I can’t hear.  Dunno.  

This was sort of a hail mary approach in that without a fix the Sansa was pretty useless…  I had only spent like $25 for the thing…  had no idea where to find a resistor and if I did at what cost and was not sure I was even skilled enough to solder in a new one.    So… what the heck… I did not have much to lose.

If the resistor is intact though… I would try to keep it and put the jumper on the output side and connect to the back jack contact. 

stickery

2- e250 refurbs.

p.s.  I would be curious if someone else goes for it and and with what results…

Message Edited by stickery on 04-20-2009 06:57 PM

Sourcing SMT/SMD devices can be a real pain, both in identifying the device, and in the physical work.  I have worked with the wee beasties for so long that I think of numbers in color.  With SMT devices, we have wee numbers(usually), and those digits are often barely visible.

Working with SMD involves a proper soldering station (temperature is a big issue), a magnifying glass, and tweezers.  There are several really cool soldering machines using heated air, like the Leister.  The processor of the Sansa (200 pins) actually has no pins on the device (about 10mm square), we use dots of solder.

In this picture is a zero ohm resistor.  It’s there as a jumper, in most cases, a mechanical bridge.

Bob  :smileyvery-happy:

Perhaps a  zero ohm resistor would explain why removing the resistor and jumpering works…  there were no markings on the resistor which connects to the rear headphone jack contact.  I looked at it under a magnifying glass.   I also knew that soldering in a replacement was probably beyond my skills to solder…

My measurement of 0.2 ohms was pretty rough…  I measured it’s twin… (the one for the right earphone), but jamming a ohm meter on it.  Was not precision science…

Years ago, when asking about preferences for bench equipment, I was told that for the serious stuff, there are three pieces you’ll need, Fluke, Fluke, and Fluke.

For the low resistance measurement, I zero the probes, and use the high resolution mode, down to .01 ohms.  I’ve had plenty of VTVMs, DVOMs, FET-VOMs, but few compare to the venerable Fluke DMM, with an occasional HP bench model thrown in for good measure.  (Oops, an engineering pun!)

Bob  :stuck_out_tongue:

great thread.  wish I’d read it before I opened my Sansa and tried to fix the jack and closed it back up.  Still no sound in 1 channel unless pushed down.  I was so sure it was the jack socket itself, after all, all that mechanical movement…  And I was able to see the connector flange at the jack end and push it in a bit to make better contact.  I knew that was the one that was open circuiting.  Darn it, it didnt help, so it must be that loose pin.  I have some experience in soldering so I know there is a very good chance I’ll do more damage. 

Wish they’d make it a bit more sturdy at this crucial point that takes a good deal of strain. Wonder if I-pods break the same way ?

dear greenbau,

here at this forum of sandisk, ipods are considered a useless piece of metal that some company with a fruit logo has made and now has been cheap and made their wheel patented. their products have become repetitive. a metal piece of c$%p with a white and sometimes black wheel. I personally all ipods except touches should break and dont break the same way so the users cant use this forum to fix their problems. 

Message Edited by NissanSkyline on 06-09-2009 08:54 PM

help, no sound coming out of one headphone at first. i took out the whole jack and tested and it was the bottom left one tt causes problems. i do not have soldering kit and i broke it accidentally. where can i find this kind of floating iron?

did they fix this issue for the fuze before it came out?

Actually, replacing the headphone jack is one of the most common iPod repairs.  From designs I have seen on the 'Pod, the jack is a separate assembly, with a ribbon connector.  Of course, I don’t think every version has this design (the Shuffle comes to mind).

The Sansa has the headphone connector soldered to the main printed circuit board.  In the new Fuze, the connector is a stout device, actually requiring considerably more insertion force than the e200 series.  On the e200v2, the casing of the headphone jack can be lifted off for access.

If you’re proficient in soldering, often the solder connection itself, and not the contact (copper) pad of the PCB is the issue.

Bob  :smileyvery-happy:

Nicely done… you saved my 260.   exact same solder break at the lower right corner connection.  followed your steps to the tee with great success.  One added suggestion when to comes time to resolder the connection in addition to putting a light layer of soder on the hot iron tip, using a scissor cut off the teeniest piece of solder possible, then using a tweezer pick it up, plant it right on top of the junture point between the two connector points.  If needed get it close as possible, then using the tweezer slowly poke it into place.  Then carefully contact with the soder iron tip just for a second until you see the solder ball bubble up and make contact with both points and pull back. It was easy as that, with just two attempts for success. You have to go very slow and very careful with a lot of light to guide you.

Peter r.

Hello team, I took apart my sansa to try to fix it and sure enough I broke the headphone jack completely off the unit.  Can someone tell me if it is still possible to repair now?

thanks

sansasux wrote:

Hello team, I took apart my sansa to try to fix it and sure enough I broke the headphone jack completely off the unit.  Can someone tell me if it is still possible to repair now?

 

That’s like me asking you “Do these pants make my butt look big?” Can you see them? No.

Can anyone here see your circuit board or broken off headphone jack? Same answer.

I just fixed my Sansa e250 using the information on this forum without the need to solder. Here is how I did it.

Model Sansa e250 V1

I removed the circuit board following instructions posted elsewhere in the forum. When the headphone jack was exposed I discovered that the soldered connector at the 5 o’clock position had indeed broken. However I also discovered that the other two connectors (one at 11 o’clock and the other at 8 o’clock) were not soldered on but were flat folded metal pins that the jack simply pressed onto. I removed the jack, straightened and widened the pins on the board with a small flat blade screwdriver and then bent the pin that should be soldered to the board in the direction that is flush against the board (with needle nosed pliers). Then when I pressed the headphone jack back onto the pins which the extend from the board the pin that would have been soldered to the board made firm contact with the point where it would otherwise have been soldered. I did not have to solder this small connection and did not have to remove the memory chip which has an edge just above this connection.

Before closing the case I added (as others have suggested) a small strip of 1/8 inch thick single side sticky foam tape to the exposed surface of the jack. This ensured that it would be held against the circuit board once the case was closed.

I have used the repaired e250 for over 20 hours without incident. I have sound in both earpieces and not static.

Hope this info is helpful to others who are trying to keep their 200 series Sansa players working.

Message Edited by htnelson on 06-21-2010 01:59 PM

My Sansa e260 developed the apparently common issue of the left earphone malfunction. 

TheMarkster’s post on 7/23/2008 described the fix I used to restore my e260. 

I rolled a small piece of electrical tape in a tubular fashion, less than the thickness of a toothpick, leaving a tail of sticky tape free to adhere to the earphone jack body.  I situated the thicker part over the bottom of the jack because I noted before disassembly when I flexed the earphone plug inward the left earphone would work. 

The tape “fix” was not as thick as a toothpick.  It must not extend into the area where the faceplate and body join on reassembly.  If you make the tape fix too thick the body and faceplate will not mate properly.

I don’t know how long this “fix” will work but I’m trying it before fooling with a soldering iron.

Thank you so much for this post - I had same problem (pad had “de-laminated”?) - I tried first to solder the pad (thinking it was ground to a leg of the micro-sd reader - that did not work. After seeing your post - I tried to attach the pad to the resistor, using  a blob of solder - that is working !

Thanks again