No Fuze device icon in source area in Rhapsody

Greetings Sandisk Geniuses,

I hope this is in the right area of the forum. I’m not too familiar with forum usage.

Problem -

Looks normal except the “Device” icon just remains the default icon.

Click on the generic “Devices” icon - right hand area states “Your device is ready for music files you own. Ready for transfer.”

When used offline - The “target” is green, as if it is updating the DRM’s.

Operating system - Windows XP - Media Center Edition - Version 2002 Service Pack 3.

Hardware - Pentium® 4 CPU 2.80GHz, 1.5GB of RAM.

Windows Media Player - Version

Sansa Fuze Version - 1.02.31A.

Rhapsody Version - V4.0, build 5.209.

When starting up Rhapsody -

The lower right “information bar” will state -

  • Updating Sandisk Sansa Fuze - Please do not disconnect.

  • Sansa Fuze Updated. Device Ready.

  • Scanning information on Sandisk Sansa Fuze. 1755 items found.

  • Loading your library. 10 percent complete.

  • Library loaded successfully. Device ready.

Tried -

  • Reinstalled Rhapsody.

  • Downloaded and installed new firmware.

  • Using each of all 6 USB ports.

  • Soft reset. ( power switch to on for 15 seconds ).

  • In Device Manager - Reloaded drivers.

  • Switched Fuze to USB/MSC mode. Device shows up in My Computer in “Devices with Removable Storage” as SANSA FUZE (K: ).

  • Switched Fuze back to USB/MTP mode. Device shows up in My Computer in “Audio Devices” as SanDisk Sansa Fuze.

  • Tried brand new Fuze and cable - acts the same - no Fuze icon in sources area

  • Tools menu / Device compatibility report / Authorize Device / Reports OK

Following is report:

Device Compatibility Report for SanDisk Sansa Fuze :

This PC reports it is running ‘Microsoft Windows XP, Service Pack 3’

This device is Rhapsody-optimized (RhapPFS)

This device supports Windows Media Digital Rights Management (WMDRM)

This device supports ‘WMDM_MTP’ communication protocol

MTP stands for Media Transfer Protocol.

This device should be compatible with the Rhapsody To Go service as it is currently configured.

This device is authorized to the current user (user address deleted) is a Rhapsody To Go member.

As configured, this device should work with Rhapsody To Go.

Rhapsody To Go members can transfer subscription content to their authorized devices.

You should be able to transfer subscription tracks to this device.

You should be able to transfer purchased or imported tracks to this device.

This device’s subscription track licenses are up to date.

This device’s internal secure clock is up to date.

  • Uninstalled Rhapsody and downloaded latest version and reinstalled.

Still no Fuze device icon.

It seems to me the problem must be in the PC hardware / software area, but the computer acts fine with other applications. What could it be ?

Thanks for your consideration. Let me know if there is a better forum area to use.


Are you saying you can’t use Rhapsody? Or just that there’s no Fuze icon instead of a generic device icon? |

Hello Black Rectangle,

There is no Fuze icon and only the generic device icon which is usually there when no device is attached. I can still browse Rhapsody, listen to music on my computer and download to my computer, but cannot access the Fuze from Rhapsody, so I can’t see what music is on my Fuze ( through Rhapsody ) and I can’t put any new music on my Fuze ( through Rhapsody.)

Thanks for your consideration,


Message Edited by TomJensen on 05-03-2010 06:20 PM

Hi Tom,

My understanding from previous attempts is that I can’t upgrade to WMP11 for some reason; maybe the version of XP. Yes, I have been using the first Fuze for over a year with Rhapsody2Go. I really need to find another computer to try before the Windows reinstall, but I’ll keep you informed as to how it turns out.



I have had the same problem when trying to sync my Fuze with Rhapsody.  What I’ve discovered was MY problem - you may or may not have already done this - I have to open  Rhapsody first, THEN plug in my Fuze to the USB drive for it to recognize it.  If my Fuze is already plugged in when I open Rhapsody, it doesn’t recognize it.

Hi kbiles,

Over the course of 2 weeks or so, I tried every possible combination and order of power up, all to no avail… but see my answer to TomJensen in this same thread. Thanks for the suggestion, though.


Hi Tom,

I just wanted to let you and all the other Sansa enthusiasts in on the status of my problem. After trying everything I could find on the forum and the kind suggestions of other posters, I took your advice and tried the Fuze on a different computer. It works fine. The correctly labeled icon came right up and I can access the songs just as I could before. Windows must have gotten really messed up on my computer, as I had tried numerous reinstalls of Rhapsody and Windows Media Player and drivers and whatnot. Thanks for all the helpful advice. ( Now to the task of backing up my files before I reload windows. Ugh ! )