'No card in camera' message in Canon EOS 60D

My Canon EOS 60D gives me a ‘No card in camera’ message when I insert one of my two 16 GB Extreme Pro SanDisk cards. The other identical card, as well as a 4 GB Extreme and a 4 GB off-brand, works just fine. Here are some details: 
  • The card is NOT locked with the little switch on the side.

  • The same card DOES work in the Canon EOS Mark IV.

  • The card still does not work after being formatted in the Mark IV.

  • It does mount on the computer normally.

  • It’s the only SD card I have that does it.

  • My other SD cards work just fine in the 60D.

  • The problem started after an event wherein the card went back and forth between my camera and laptop (15" MacBook Pro 2.66 GHz Intel Core i7) about 10 times. The last of the photos had just been copied to the laptop, and when I put the card back in the 60D, the message appeared for the first time.

  • The card has worked fine in the 60D since being purchased several months ago.

Follow-up: As soon as I posted my original message, I noticed the card in question is actually breaking in two. It’s splitting along the seam, starting at the corner nearest to the lock slider. Think that might be it? :slight_smile:

Still, I wonder why it works in the Mark IV and why it mounts on the computer…

Had that message today on my EOS 60D and ScanDisk 32GB.

I used some compressed air to blow carefully into card slot - worked again immediately, hope it stays like that :slight_smile: