New 8gb fuze getting "USB Device Not Recognized" on second connection to PC

I purchased an 8bg fuze two days ago.

I came home opened the package, connected the unit to my Dell E1505 (Win7) and it was immediately recognized and some sanza application came up. I was suprised to see it since had not installed anything related to the sansa on my computer. I closed the application. I let it charge for a while, then disconnected it, turned it on and it worked well.

I then took it to my desktop PC where I have all of my music, and connected it. I got a message “USB Device Not Recognized” My desktop PC has Win Vista so I thought maybe it was a driver issue. I inserted the cd that came with the sanza thinking maybe there was a driver on it, but nothing useful was on the disk.

I disconnected the cable from my desktop PC and reattached it to my laptop, and now I get the same message “USB Device Not Recognized”

I tried the following:

pushing the power switch up for several seconds while connected to the PC. After a few seconds it went black. I powered it back on and same message.

restoring the factory settings same message

changing the USB connect mode, powering down both the pc and the sansa the reconnecting three time for each setting and same message

connecting to every usb port on both my desktop and laptop pc same message

manually install every type of legacy mtp device one at a time, rebooting same message each time

What now?

Hi,

When I plug my Sansa fuze into the USP port, I hear a tone from the computer which used to indicate the device was connected.  In fact, according to the screen on the sansa fuze, it says “connected”,  yet the computer no longer brings up the "windows Media player options, nor does it recognize the device as being connected.  This is just since before Christmas.  What am I doing wrong??  This is making me crazy!!

Can someone please help?

Thank you,

GE

All the drivers you need are already in Windows: the basic USB driver for MSC mode, or the MTP mode driver within Windows Media Player (it has to be version 10 or higher, but Vista has that).

Try some of the basic steps here, and let us know if they don’t work (or even if they do).

http://kb.sandisk.com/app/answers/detail/a_id/42/session/L3NpZC9QRU9rNjlTag==

Message Edited by Black-Rectangle on 01-16-2010 10:31 AM

Yes, you are miracle workers!  I had the Yellow sign on the Sansa fuze device and followed your instructions for refreshing the drivers and it worked!!  Thank you so much!  I was about ready to toss my sansa fuze and buy someting different!

Thanks again for your helpful support,

Ginny

What you have to do is go to settings/USB mode/ MSC  If MSC dosnt fix it then MTP will:)