Need to remove nonworking music files from clip that are using memory

I loaded unconverted music files onto my new clip and they do not show anywhere but they are taking up memory space. How do I get rid of them? I have since put music onto the clip and they all work fine. Do I have to clear the clip of all the files?

Connect the Clip to the pc in the other USB mode. then they should show up. Delete them, then change the USB mode back. Use either MTP or MSC mode and stick with it. Files loaded in MTP only show on the player on the pc when connected in MTP, and those loaded in MSC only show in MSC. Auto connect might connect in MTP or MSC, so it should be avoided. The default setting is auto.

Can you explain to me what exactly the MPT & MCP thingy’s are that you’re talking about?  I think this can help me with my problem also.


MTP and MSC are the two different ways the player can communicate with the pc via the USB connection. There is also an auto setting, which can use MTP or MSC. The default is auto, but you should choose either MTP or MSC and stick with it. MSC treats the player as an external storage device, similar to an external hard drive. MTP mode treats the player as a virtual device, not a physical device. MTP mode is needed to sync with Windows Media player or other media players, and to transfer protected music to the player. Unprotected music can be dragged and dropped or copied and pasted to the player using Windows Exporer or My Computer in either MTP or MSC mode.