Need to free 90 MB but cannot get into the settings

Hi All,

I have the 8gb with the 4gb card, I am using kubuntu as my O/S. I have not updated the firmware from what is out of the box.

My problem is that I tried to use my card like a USB drive and copy some tv shows for my friend. this caused my Dolphin (directory browser like Explorer) to hang. So I wait for a while to see if it will resume and after about 5 mins I decide it  had enough time. I load my command prompt and check the process and it says it confirms it is hanging so i kill it. I unplug the Fuze to check if it has copied any data at all but then it just says it need 90MB of space for the music DB. At this point I am a bit confused so I switch it off and on again, same message. It is also no longer recognised by my O/S as an external device. I start to google for my error message and find that this has happened a few times for other people.

I have tried holding the ON slider up for 20 seconds and then restarting the Fuze but same error message. I then switched the slider to HOLD and held |<< and inserted the cable to see if this could help bring it back to life, no joy.

Last night I tried to send an email to the support address and got an automatic reply saying to visit #URL# to set up an eBox account. maybe someone could tell me the web address it was referring to? If anyone has anymore suggestion as to what I can try please add to this thread.

Thanks in advance,



Simply click on the SanDisk logo in the upper left corner.  This will redirect you to the corporate (red) side of the site.  Then click on the Support tab, then you’ll see the Register / eBox button from there.

The eBox, or contacting via telephone during business hours, is the fastest method to contact Support.


Thank you for the quick response :slight_smile:

Welcome to the Sansa Forums!


Ok i have made a little progress but not sure if it is real progress.

I managed to get to the settings screen by using the |<< and HOLD trick.

I started to format it about 2 hours ago and it says it is still formatting now.

Does it normally take 2 hours+ to format or do you think it is hanging?


I got this error last week while trying to use SMC to transfer a video.  I have read posts that SMC is quirky and I have found that as well.  It appears that I had two SMC’s open at once.  I didn’t think that was possible, but when I went to the task manager, it showed two…(I am running XP).  I closed them both, disconnected the Fuze, reconnected the Fuze and opened SMC again.  That fixed that problem.  I still didn’t get the video loaded as it hung up…but at least I didn’t get the “…free up 90mb” error again.  

Message Edited by bragl123 on 03-25-2009 02:30 PM

Sorry maybe it is blindingly obvious but what is SMC?

Message Edited by Monkieboy on 03-26-2009 02:45 AM

SMC = Sansa Media Converter