Need tech. help: restore partition(s), filesystems etc.

This question is for the gurus and SanDisk tech help.

I bought a Sansa Clip today, and in learning to use it with my Linux (Ubuntu Hardy Heron) system, messed everything up. I ended up using a partition editor in Linux to completely wipe clean the Clip, then give it an MSDOS disklabel, one single partition covering the entire 1GB memory of this Clip, and formatted that partition as a FAT32 filesystem.  However, as you can guess, that wasn’t good enough.

I can still connect the Sansa Clip to the computer and can partition and format (filesystem format) the Clip, but I am hopeful that someone can tell me exactly how many partitions to create, their sizes, what files should be placed in which partitions, what the filenames should be. Basically, I’m trying to restore the Clip to usable condition by understanding some of these technical issues. I am a fairly experienced computer user (Linux and Mac only, not much experience on Windows, sorry) and am not afraid of trying anything. (That’s why I messed the Clip up so bad.) :slight_smile:

I have tried many or most of the troubleshooting procedures mentioned in this forum, but this problem is beyond their scope I’m guessing, since my Clip still gives me a “Not enough space for music DB” error message when disconnected from the computer, even immediately after deleting the partition(s) on the device and creating one or two new partitions (I tried creating 2, one as a 16MB partition, FAT16 and later in another attempt a FAT32).

Anyway, if someone with technical expertise can suggest what to do, it may help me and some other forum reader(s) who like me are somewhat technically inclined and capable, just clueless about this particular cute little device. :slight_smile:

If there are any savvy Linux users here at the SanDisk forums, it would be a great favor if you would make an image of your Sansa Clip’s memory using the program dd at the command line in a terminal, and then make that image available to me and possibly others who unintentionally or intentionally (but for what they thought were good reasons) hose their little Sansa Clip. OR, perhaps the good people in tech support at SanDisk have a partition/filesystem/system-files restore utility or a disk image? (hope, hope) :slight_smile:


Message Edited by xscd on 10-13-2008 11:44 PM

You should only have 1 partition.  FAT32 will do.  I’m guessing you are getting the message because none of the folders/DB files are there.  Are you able to navigate to the Settings menu?  If so, there should be a Format option you can use there to reformat your Clip and create these folders/DB files.  If that doesn’t work, grab the latest firmware update and place it on the Clip.  This should also create the required folders/files.

Thank you puddle glum. However, I think the problem may be a little more complex. I can get to the Clips menu using a trick to bypass the “Not enough space for music DB” message (I power on, then place the power slider to “Hold” and press the middle button of the navigation area of the Clip for a few seconds, then release the Hold to access the Settings menu. But the Sansa Clip’s own “Format” process just occupies the little device for as long as I leave it on, which has been up to an hour at a time.

When I read all the advice about reformatting the Clip as a last resort, I took “reformat” literally and reformatted the device from scratch using a disk partition and filesystem utility in Linux (I have never used Windows). As the result, I wiped the Clips flash memory clean, believing the device’s firmware would repopulate the new FAT32 filesystem with whatever directory structure and system files it needed, until I could find a way to update the firmware.

I discovered that Sansa’s “official” method to update firmware was not to offer the firmware file at all, but instead to use an application, the Sansa Updater, that is a Microsoft-Windows program only. I tried to use that program under the Windows emulator Wine in Linux, but the Sansa Updater hung at a certain point very early in the process, gave me a window but the window remained empty. I later discovered how to install firmware manually, and found the links to the firmware files themselves here in these forums and elsewhere. But by that time I had of course reformatted the Clips memory and there was no 16MB-FORMAT partition (or at least, it might be a partition–I don’t know which partitioning scheme is used in the Clips (MSDOS, with 1-4 partitions one of which is an optional “extended” partition?), how many partitions there actually are in the Clip, how large they are and exactly how they are laid out in the Clip’s flash memory, which filesystem is installed on those partitions, and what the directory structure should be and which files are mandatory.

This is the type of technical data I’m trying to find out. Easiest would be for another Linux user to make an identical image-file of his or her Sansa Clip using the program dd at a Linux terminal command line, then email that image to me or post it so that others in my position might be able to benefit from it as well. I could write the image file directly to the Clip, bit by bit, to make my Clip an exact duplicate of the good, working one. :slight_smile:


@xscd wrote:

When I read all the advice about reformatting the Clip as a last resort, I took “reformat” literally and reformatted the device from scratch using a disk partition and filesystem utility in Linux (I have never used Windows). As the result, I wiped the Clips flash memory clean, believing the device’s firmware would repopulate the new FAT32 filesystem with whatever directory structure and system files it needed, until I could find a way to update the firmware.


_ Too much knowledge can be a bad thing! _

Yep, “D’oh!”   In addition to posting my tale of woe here at the SanDisk Forums, I wrote an email to SanDisk technical support a couple days ago. Have not heard back from them yet, but I’m hoping to. There’s nothing physically wrong with the Clip; all I did was completely erase the contents of its flash memory. :robotsad:

Anyway, I’m hoping that SanDisk tech support has an image file (a bit-for-bit exact copy of the contents of a working Clip’s flash memory) that I can copy to my Clip. I really like this little device and hate to see it dead in the water so to speak, just sitting by the computer unusable.

Message Edited by xscd on 10-15-2008 02:47 PM

Still haven’t heard from SanDisk technical support, but as happens so often when people post problems in forums, I finally managed to solve my own problem despite a lack of help. :angry:

SO, for all Linux users who may have a SanDisk Sansa Clip and are having problems with it, here’s a brief review of the problem, and a solution.

How to restore a hosed Clip

I recently bought a tiny and cute Sansa Clip “MP3 player.” It had some problems mounting in Linux (had old firmware), and after consulting various online forums here and at and, I read numerous reports that said the same thing: update the firmware, or if all else fails, reformat the Clip.

I downloaded SanDisk’s “Sansa Updater” application and tried to run the Windows-only program under Wine (a Windows emulator) in Linux. No luck; program hung. Then-- before I discovered that one could manually update the firmware–I reformatted the flash memory of the drive using gparted, a partition-and-filesystem-format-from-scratch program in Linux. This was before I learned that “reformat” at the forums meant “use the Clip’s own ‘Format’ command.” Stupid me!

So–  The Clip was then useless, a cute little plastic brick beside the computer. I contacted SanDisk tech support (still haven’t heard from them, a few days later) and wrote messages on all the forums pleading for help.

As is the case many times, I ended up helping myself. I did some more research and tried lots of ideas. One of them worked. The solution is in two parts.

Important Note
Before trying the steps below, if your Sansa Clip has not been completely rendered useless yet, you may be able to use its own Settings–> Format command to reformat the Clip. That is easier and better, and then you can update the firmware manually (check the SanDisk forums or forums for firmware versions), or using the “Sansa Updater” program.

How to get a useless Sansa Clip working again

  1. Reformat the Sansa Clip’s flash memory and install a FAT32 filesystem. You can reformat it in Linux using Gparted, but the Clip still won’t work because the Clip wants the exact settings that Windows uses when it formats a blank disk. However, reformatting the Clip in Gparted will serve the purpose of ensuring that it absolutely won’t work nor be recognized by a Windows machine. So go ahead and do that once if you like. Then plug the Sansa Clip’s USB2 connector into a machine running Windows or Vista. Then use Windows file manager (Windows Explorer) to try to open the drive letter of the Windows-detected USB device. Windows will give an error message saying the drive is unformatted, and offer to format it for you. Choose FAT32 filesystem and UN-check “Quick format.” Then let Windows format the Sansa Clip’s flash memory.
  2. After the Clip is formatted in Windows, remove it (“safely remove hardware” icon in system tray, followed by disconnecting the USB cable). Then go to and download the “Sansa Updater.” This application is for updating the firmware of already working Sansa Clips, but believe it or not, it can also completely restore the firmware and directory-structure and files that the Clip needs to run. After downloading and running or installing the Sansa Updater, close the program. Then plug the Clip back into Windows. It should be recognized and the Sansa Updater program may automatically launch. If not, then find the Sansa Updater in the Start menu, launch it and follow its directions. It will search for your Sansa Clip, then download the latest firmware, then restore your used-to-be-useless Sansa Clip to a pristine, factory-approved, completely updated state that works great with Ubuntu Hardy Heron and even now supports OGG and FLAC!

Best wishes all. Hope this helps other Sansa Clip users. :smiley:

Thanks for posting your solution, as help to others!   :slight_smile: