my volume button is broken.

the volume button on my mp3 player is broken. do i need to take it back to where i bought it

Yep, return it. Let me guess…it’s the up volume button. This is a major problem with the clip. I’ve seen a whole bunch of them. Most of them are completely missed solder on the top pad of the up volume switch. In time it breaks free or flexes back and the outside button quits making mechanical contact.

Return it if you can or RMA it.

Further notes on the Clip volume button breakage:

I had the same problem. I found some information that indicates that the art of soldering has improved over the years, to a point where it is 99.9999% perfect. Every electronic product has hundreds of solder connections in its construction and a computer board, for example, has thousands of connections. The chance of a board failing in a 5 year life-time is less than 1%.

Also, I believe this issue involves what is called a Cold Solder issue that happened at the factory. A cold joint is a joint in which the solder does not make good contact with the component lead or printed circuit board pad. Cold joints occur when the component lead or solder pad moves before the solder is completely cooled. Cold joints can be recognized by a characteristic grainy, dull gray colour, (this is what I found when I looked closely at the contacts of the switch), and can be easily fixed by removing the old solder and resoldering. 

(I am also entertaining the idea that there may not be a ‘stop’ on the volume button. That is to say, something to stop the switch from being over pressed by the button. It’s a tiny switch, and if what ever pressure is applied to the volume button is transferred directly to the micro switch, I could see that it might end up being just too much pressure for it to handle so that either the contacts break off the board, or perhaps the switch itself will break over time) 

It seems logical from these two points, and the apparent frequent identical failure of this specific switch, it really is a manufacturing fault and not a user fault.

Contacted Sansa, but without packaging and receipt, no service. A pity, since everything else about Sansa and Sansa products seems so wonderful. I personally think a company should stand behind their products on manufacturing defects, regardless. 

For an idea of how service/non-service works, transcript included here…personal details edited out. Reads from bottom to top by date.



Message Edited by krom on 06-14-2009 03:49 PM

Message Edited by krom on 06-14-2009 03:49 PM

Message Edited by krom on 06-15-2009 04:58 PM

1 Like

In case this will be of help to anyone.

Further to Clip Volume Button breakage. Not having any satisfaction from Sansa, I decided to attempt my own repair. There is a very nice example with pics elsewhere in this forum, (‘Things to do to your clip when it’s dead’) but it is hard to find since the posting title does not reference volume or button, so I will post my own example here. This is a very difficult job to do for a number of reasons, unless you are an expert at this sort of work. It is all so very tiny! The heat has to be just right in order not to damage any components or the board. Also, you have to have a very very fine tip. I custom made an adaptor tip to fit to my soldering iron. I used a 500 watt lamp up close for light, tweezers, and two stacked magnifying glasses! And you have to have a very steady hand.

All contacts have to be cleaned and a thin coat of clean solder applied before final assembly. After two hours of work, I got it all put back together and it worked! Yaaay! Here are before and after pics. The arrow on the left is the up volume switch. In the Before pic, you can see the switch (which came clean off) sitting loosely just above where it should be, for reference. 

Before Repair

before repair

 After Repair

After Repair

Also, if anyone has a black 8 gig with this specific problem only and can’t be bothered to go through all the work or $ to fix, and you will just be throwing it out, you could send it to me… :slight_smile: I’ll pay postage and I would love to have an 8 gig. (I wouldn’t do the repair to send back, there are too many possible complications)

Message Edited by krom on 06-14-2009 04:06 PM

Message Edited by krom on 06-14-2009 04:12 PM

Message Edited by krom on 06-14-2009 04:16 PM

Message Edited by krom on 06-16-2009 10:42 PM

Message Edited by krom on 06-16-2009 10:43 PM

1 Like

The ones I’ve seen are not cold solder. The upper board pad was not pre-tinned at all so the only solder that existed was the pre-tin on the component. This is a no-no for reflow soldering. Not enough solder on the connection, so it fails mechanically.

Note also that dull looking solder joints are quite normal for lead-free solder used nowdays. They should be shiny, chrome looking for lead type solder, but may not be for lead-free.

Hi there.

My daughter has one of these and also has a problem with the volume button.I was going to open it up to have a look inside but how on earth do I get it open!

Many thanks for any help given.


Message Edited by davedee_1 on 07-05-2009 05:14 AM

The reason you can’t figure out how to do it is the Clip is not made to be opened.  Some have pried the 2 halves (top and bottom) apart, carefully starting at one of the openings.

Volume UP control stopped working, but after getting a glimpse of the Sandisk insides posted earlier, decided to try a repair.

The clamshell needs to be carefully pried apart.  Used a mini flathead screwdriver around the seam.  The guilty volume control immediately fell out upon opening, indicating a poor solder connection to the circuit board.

Pulled the lithium battery away from the board for easier access.  It’s secured only by sticky tape.

I have neither the confidence nor the right tools for soldering such a tiny pair of connections, where the volume control button assembly sits on top of them.  However, tried this idea, and it worked:

Placed two tiny strips of aluminum foil on the board contacts to insure contact, then GLUED the button assembly down holding them in place.

Used a tiny dab of a strong glue in the center where its two tabs position the button assembly on the board, (I used Locktite) clamped it down, and let it cure.  Tested, and all buttoms worked properly.  Re-assembly was fairly easy.  Just make sure the exterior volume control rocker is in place in it’s shell before snapping the two clamshell halves back together.

1 Like

I had the same issue with a broken up volume button and fixed it the same way as Home Engineerl, with the sight difference that I used Krazy Glue to reattach the swithch and skipped the aluminum foil.  So far it’s holding together. 

@paladin1420 wrote:

I had the same issue with a broken up volume button and fixed it the same way as Home Engineerl, with the sight difference that I used Krazy Glue to reattach the swithch and skipped the aluminum foil.  So far it’s holding together. 

Thanks for the report–good to hear and know!   :slight_smile:

Same problem. Tried to fix it with glue. It didn’t work.

It seems like there’s no contact anymore (before, I could put the chip in place and increase the volume, now I cant).

Tried to put dissolvant to get rid of the glue and get the contact back, didn’t work either.

Tried to scratch away and get a better contact, didn’t work either.

Not sure what to do now. Perharps I will try tin fusing, not sure. Honestly it starting to piss me off.

It’s my second Sansa Clip broking (first had a screen problem after a fall) in 3 years.

Not sure if I’m gonna buy a third one…

If you still are within the warranty period (1 year U.S., 2 years EU), you could try asking SanDisk to replace the player for you . . . .

Technically, I am, but since I opened it to try to fix it, I no longer have the warranty.

And honestly, it was partly my fault, as the button broke because I’ve dropped it (still, only from less than 1m). But because of that, I doubt I can get an exchange.

(I have to confess on the other side that the first one was completly my fault, as I had really badly damaged it).

It’s annoying, but aside from that I’ve been quite pleased by the player.

I’ve commanded another one for 36€, with a protective silicon gear this time, and I’ll try to be more careful in the future.

I’ll also try to fix my old one later, and post here if I can fix it.

Anyway, thx all for the feedback. :slight_smile:

At least I was able to try to fix it (and learned that glue and electric connection are bad combo, haha, costly lesson though).

You might try contacting SanDisk and explaining that you only tried to fix the player once it failed. SanDisk could respond positively. It’s a cheap (tellfree) phone call.

That is, “tollfree” . . . .

Same problem here with 4MB Clip+, and a tiny drop of super-glue between the twin holes in the MB re-attached the switch and so far so good (only 2 days). I use Rockbox, and it has volume control under Settings, but the control is a hassle to get to (and to get back from), so getting the up-vol. switch back is very nice. The worst part of the job was getting the case apart…ugh. The case has to be lifted OVER the USB connector, so beware. You’ll need visual magnification and fine tweezers to hold the switch in order to place its plastic pins properly in the twin holes. I applied downward pressure on the switch as the glue was setting up in order to ensure the contacts were mated.

Dear Krom:

Ten years ago, you provided some very useful information about efforts to repair broken volume buttons. Along with the text, you also provided Before and After Repair photos. Unfortunately, those photos don’t appear within the text, and I’m sure they would be very helpful.

I still use the Sansa Clip Zip MP3 players because I need ones that are compatible with Audible audiobooks and, in my view, this player is far superior to its successors, Sport and Jam, which frankly are junk (and smarphones are heavy to walk with). Of course, it’s difficult to obtain them, and thus it is disheartening when something goes wrong with my precious Clip Zips. Two now have broken volume buttons – one with just the up button and one with both. I can use them on a speaker with sound controls but not with headphones, which is inconvenient. I’m not confident that I can find someone to fix these (don’t trust myself) but I’d like to try.

I strongly doubt that you will get this message after such a long time, but this is the only way I can see to try to contact you, so I might as well try. If you do see this message and can still provide the photos, I would be most grateful.

Sincerely,  “Elbara”  aka Elinor,