My Ultra 64gb card seems to have died.

Same situation happened to me!

I ordered another card today, but after finding this forum, thinking of cancelling order and purchasing a different brand.

Contacted SanDisk about returning my defective card, see what they will do for me.

The first time my card went defective I was able to reformat. Now my computers wont even recognise I have inserted it. when trying to reformat while it is inside camera both of my computers state Windows cannot format.

Thought about buying 32 GB cards, the forums tell me theese also have similar problems!

Same here with my Tablet (Asus TF300)

My 64GB card stopped working last evening after transfering files from my PC to the card.

Card doesnot work at all anymore, tried with 3 different PC’s (XP & Win7) and my tablet does not see it either ???

Placed a call with Sandisk this morning, no news yet. :frowning:

Same here with my gopro hero 3.  SanDisk I am so disappointed, give me back my money!

Yep My Scandisk ultra micro SDXC 64Gb card died the 2nd time I used it… not at all happy…  just filling up the last of the card, said full then no card… Tried several computers and readers will not even be recognised.  On a once in a lifetime round the world expedition and even thought downloaded all my stuff asap still lost a load of stuff never to be gotten again. Using a GoPro Hero3 funny how they no longer sell these cards!  The Verbatim one from my phone works great in My Hero3 Black so I’d recommend these… sending back for a refund as not fit for purpose.

Just checked the Scandisc compatability checker on this site and still recommending The Ultra and New Extreme’s for the GoPro Hero 3 black but here everyone that’s tried them seems to have problems… 

I bought my gopro 3 black on March 1 with the 64gbs sandisk memory card that gopro recommends. I’ve done the last firmaware update on April 8. Today, 25 of April, It happens to my card. I put the camera recording and she automatically stop recording, for 3 times. I started to get worried with that so I turnt the camera off and on again. and it was there that appears SD ERR on my Gopro. I tryed format the card on the camera and nothing. I turned off the battery a few minutes and card too, and the error still there. Then i went home, run to my computer to try format the card. The files are there and i can play it on windows video player and copy to my pc, but i can not delet them or format the card . it says " windows could not complete the format"…

GOPRO and Sandisk have to assume the problem!!

Hello I would like to know the error corrected because I want to buy takyu Sde tsard.

I’m having a similar issue with my Hero 2 so its not just Hero 3 owners. The camera recorded and will play back videos from the camera but when I insert the card into my SD reader on laptop it shows the folders on card as empty. What’s more puzzling is the icon for the folder shows images but clearly the PC sees nothing in the folders. Irritating to say the least. We all agree the reason we purchased the 64GB card was to record hours of video with out having to switch cards. What’s the deal? I don’t want to keep loosing content, like many I was someplace I will prob never be again on vacation with family. Feeling burned!

I wish I had read thes posts before I ever bought the **bleep**ng 64GB SD card for my GoPro Hero 3 camera. **bleep** You Sandisk!!! Why are you not responding to anyone’s problems regarding this. I am just another very dissatisfied customer who will boycott your products and I will spread the word that your products suck and you do not reply to customer’s complaints about your products. You need to reimburse myself and all the other people who are angry with you for this.

@kobeejay wrote:

_ Why are you not responding to anyone’s problems regarding this. _

Probably because this is a user’s forum, not an official “Tech Support” or “Customer Service” forum. The only SanDisk employee that frequents this forum with any regularity is the Admin. And he’s also got a full-time job already.

You should avail yourself of the support avenues SanDisk does offer:

GB am getting a NO SD card error code when I try to use a Brand New SanDisk Ultra 64GB in my GoPro. My MacBook will not recognize it when I try to perform the on line update. A 32GB SanDisk works fine.
Could I have a Bad SD card?

More likely an older card reader that can’t handle the newer SDXC format, so the computer cannot see the card.

I have the same problem with mine,  Is SANDISK going to do anythink about it, at least they should return the money or a new (different) card, oll the work, and memories are complete lost, and i dont see any response from SANDISK…

@ponceleon wrote:

I have the same problem with mine,  Is SANDISK going to do anythink about it, at least they should return the money or a new (different) card, oll the work, and memories are complete lost, _ and i dont see any response from SANDISK… _

And since this is a _ user’s forum _ and not an official Sandisk Tech Support forum, it’s highly unlikely you will see any response here from them either.

Instead of whining and assuming it’s all SanDisk’s fault, why don’t you explain exactly what your problem is, what you have been using the card in, etc. and maybe someone here can help you. Or if not, you can always call SanDisk Tech Support directly. That is after all, what they get paid for. There is always the possiblity also that the fault does not lie with the card itself too. If the card is deemed defective, they will replace it for free under warranty for you.


Thanks for your comment, the issue I have its already explain, one day i put it out from my go pro hero and stop working, its only recogize 32 mb. the only place where i found people with de same issue was here, but there is no solution. I will try to contact sandisk directly, but what I really want is my card working.

The Sandisk Ultra card on my Note 2 allows for run/edit/delete files just fine, until I reset the phone. Then all the files will return exactly the same as they were.

Basically, my photos until 2-Nov-2013 are all there, and I can create new photos, but the moment I reset my phone (or take the card out), all photos after 2-Nov will be gone.

The worst part is I can’t even format the card – even by Windows Disk Management. It goes up to 99% before it gives an error like “The format has not been completed”.

Formatting by phone is the same. The phone will say “Total Space: 59.47GB”, “Available: 59.47GB” after I manually delete all files using Astro File Manager, but the moment I try to format the card, it checks it and comes back with the same old files.

What the heck is going on? Any help would be appreciatedv

SAME PROBLEM!!! (I bought from sandisk authorized retailer too) , I had my Ultra UHS-1 Class 10 64gb for 1~month then it started getting curruption, I was able to back up most files, but at 99% copyinh the card died.

Android ‘fdisk’ shows the data as 32MB, it is also locked I cannot create partitions or anything, windows and my sdcard reader can’t even read it, the usb-reader shuts off instantly (no lights), my macbook shows it as 32MB just like android…

the card just stayed in my tablet so it was never abused and its only a month old, the quality controll on these cards is horrible, and they are expensive , MY no name brand cards last longer for example TopRAM and transcend no problems use the every day I expected higher of SanDisk…

Command (m for help): p

Disk /dev/block/mmcblk0: 32 MB, 32096256 bytes
4 heads, 16 sectors/track, 979 cylinders
Units = cylinders of 64 * 512 = 32768 bytes

              Device Boot      Start         End      Blocks  Id System

I just hope the RMA proccess is easy and has a quick turn around this error should not happen to so many people, sandisk should really do advanced replacements for this issue as I’m sure they know by now these cards are all effected by this issue.

I have had the same thing happen with my card on two different vacations.

SOLUTION: inset card into reader and into a Mac. Go to Disk Utility and verify disk. It will show errors on **bleep**. Fix those errors. The process should take 30 seconds in total. Unplug your card reader and plug it back in. Your card is now mounted and all the pics should be on there.

Has anyone sent their card for professional recovery?

My 64gb card got corrupted when I forgot to unmount from tablet and it says blank SD on the phone/tablet

I got around 8k photos and 100 videos in there. I tried several photo and data recovery softwares but many photos and videos seems to be missing still. Some are even incomplete (half photo and just gray on the other half).

I sent and enquiry to LC technology asking if it’s possible to recover these damaged files, he never really gave me a definate answer. It’s so expensive for recovery. I also tried their RescuePro Deluxe demo but at some point it says it reads 20,000+ errors (uh…wow?)

Yes I know I have a lot of photos, since taking photos is really convenient with phone camera. Most photos are pictures of my cat when she was young and tiny… contains a lot of memory. I should’ve backup up from time to time but 64gb card won’t load directly on computer since start. I could only load it via phone/tablet that is plugged into phone.

Argh, I really hate these cards. They get errors so easily…

Sandisk really? This many users talking about it and no official response from a representative from Sandisk? Where are you guys?  Your customers need your help here.  

My card is unable to be formatted / written to anymore.