My Sansa won't turn on or off

I’m really pleased with my Sansa which hasworked well for a few years; but all of a sudden it won’t turn on or off. If I plug it into a USB then it charges up and works fine, but it’s like the ‘power’ button doesn’t exist. It won’t recognise I’m touching it at all. I know it’s a long shot, but any help would be gratefully received! Thank you.

It could be a physical button/connector issue.    :frowning:

Or, hopefully, it could be a software glitch, which can develop over time.  I would try manually reapplying the latest firmware, easy to do (see the firmware sticky thread at the top of this sub-forum).  You also could try reformatting the player from its System settings, which can clear up mystery issues–note that this will delete user content, and so save anything you want to keep to another device first.

1 Like

Hi, thanks for your reply. Resetting it hasn’t worked, alas. I will try the firmware thing when I’m back on my laptop.

Does the device power up when plugged into your computer, but shuts off when unplugged?

If so, It’s likely a loose/broken connection from the battery to the device (internally). You didn’t say which Sansa player you have, but this was a very common issue on the original Clips (round scroll wheel), and some of the newer models as well (Clip+).

If this is the case, it is possible to open up the case and re-solder the connection. There are guides/instructions on how to do this online.

Thanks for your reply. It’s a Sansa Clip and a few years old! The only way to turn it on is to plug it in. I can’t turn it off either, so I have to wait until it gets to the end of a track and allow it to shut down naturally.

So the player will work after you plug it into your computer, and then stay on after you disconnect it? That doesn’t sound like a battery lead issue . . . did you try (manually) re-applying the firmware and/or formatting as Miikerman suggested?

I’ve reset it but to no avail.

I tried using the firmware download, and it said that the .exe wasn’t an valid Win32 application.

I tried doing it the alternative way, and can’t find a programme to run the BIN file from. Lost! :frowning:

You don’t ‘run’ the .bin file. You simply copy it to the root (uppermost) directory, unplug the device after transfer is complete and the player will install it itself.

Ah I think I’ve done that then - again to no avail. Unless I’ve copied it to the wrong place. The player doesn’t turn itself off, but when I disconnect it it says “disconnecting” and then goes back to normal. :frowning: :frowning:

Did you place the bin file at the player’s “root” level, that is, the top level of the player?

You may be trying to install the wrong f/w version. There are sveral Clip variants and they all take a different firmware. What Clip model do you have? You never did say. And what firmware are you attempting to put on it?

If you try to put a different f/w onto a player not made for it, it won’t do anything. Kinda like what you say is happening.

Oh dear, I thought I’d got the right one. I have just a SanDisk Clip+. It says it’s version V01.02.17A. You can see from the screenshot where I put the BIN:

This is my clip:

And this is the error message I get when trying to download the firmware using the firmware software:

Thank you for your continued replies!

As I thought, you’re attempting to put the wrong firmware on it. According to your screenshot, the file name is m300a.bin.

If you go to this page here on the forum & download from the link that says

Manual Firmware update

Firmware Download for All Regions - Click here to download (you can actually click on this link; it will take you directly to the download), it will download a file named “”.

This is a compressed file. Once downloaded to your computer, click on it and it will extract your firmware file “clppa.bin”. THIS is the file you copy to your root directory; just as you did the other one. When this is copied, unplug your player and it should install the lateast firmware for you and you’ll be in business. :wink:

You can delete the m300a.bin file.

Thanks so much for your reply! I have done as you instructed above and yes now the firmware is updated, but the power (or lackthereof) of the power button hasn’t changed. I guess it’s a physical issue. What a pain! Not much I can do about it. :frowning:

That’s too bad. These are a great little player and usually quite dependable. Unfortunately, being discontinued for so long now drives the price, even used or re-furbished up to more than what they were when current & new.

Here is one wild and crazy idea.

If your Sansa device has a power saver mode, then set that to 5 minutes of inactivity.  Then when you press Stop the device will shut itself off after 5 minutes?  Then, maybe use one of those low cost USB power banks to turn the device on when you are on the go ???

Great idea, I’ve got a portable USb thing in my car. The player still works, so I’m fortunate from that respect, but it’s just a bummer! Thank you all for your help anyway.

And just a last stab at this:

I know that you wrote above that you had re-set the player, but did you also try reformatting   it under the System settings?  That sometimes will fix odd circumstances.  Note:  reformatting also will delete all your user content on the player, and so save anything to your PC that you want to keep first.

I don’t have high hopes for this, but can’t think about anything else, save opening the player up physically and checking the power button and the connections to it out . . . .

Thank you; yes I did try that, and also to no avail. Ah well, at least it still works.