My Sansa won't start!

I got my Sansa Express at least two years ago on July 2nd, 2007.

Okay so just during June or August I tried adding new songs into my MP3 using a Mini Dell Laptop, and it deleted all of my songs and I know why now.

Now, I’m trying forever downloading all of my 105 songs+ into it now.


-today, saturday oct 31, 2009, I decided to add new tracks using CDs, using the Window Media Player’s Sync. It worked out fine as usual, fully charged before I installed it into the computer, perfect.

 After I was done choosing CDs and tracks, and ripping I added of course. It read to me ‘YOU CAN NOW REMOVE DEVICE’ and so I did. It shut off automatically, even before I had removed it and it won’t start anymore. This happened at least twice NOW!

 I’m afraid it’s DEAD!

Message Edited by iROCK on 10-31-2009 11:21 AM

Message Edited by iROCK on 10-31-2009 05:20 PM

Did you try doing a hard reset? I have had a similar problem where I could not start my Sansa Express and I thought I had buggered it for good. I did a hard reset and it fixed it good as new. (Can’t remember if hard reset deletes all user files or not.)


From user manual:


Question: How do I perform a hard reset on the Sansa Express player?

Answer: To perform a hard reset, press and hold the Select button while pressing the

Volume Up (+) button.


(The "Select" button is also the power button beside the hold button.)