My sansa clip won't turn-on

Yep, SanDisk with a warranty replacement.  I’d telephone them again and tell them that’s what you want/need.  If the battery lead has become disconnected, the only way to repair it is to disassemble the unit and re-solder the lead–not for any casual user to do (and it would likely void your warranty).

yes it’s true about the battery. No matter what i did, no matter what mode i was in, as soon as i was unplugged from the  usb to my puter i was dead in the water and the clip won’t turn on. so as a last resort i opened the clip. it clips together and isn’t glued so you just have to be careful in how you pry the clip apart and keep track of how the slide on-off and volume pieces go. be careful how you pry cause you mangle the soft plastic as you go. what i found were 3 very little wires come off the battery, red, blue and green i think, and are soldered to the printed circuit board. my red wire had broken away from it’s solder joint, hence no connection. if you’re good with in-close spaces, you can trim back this wire and epoxy it back to it’s place on the board. i held my battery in position with a wad of tp underneath it and a rubber band. then when i put the wire where it should go the interface lit up. while it’s lit (meaning the connection’s made) i dabbed a drop of epoxy onto the connection. i suppose you could solder this connection, but you’d need a very small soldering iron and like i said it’s in a very small space. anyway, i had to try something or else just toss the clip as i tossed the receipt for it already. hopefully this connection lasts for me but, so far so good. good luck.

I have this same problem, but I can actually get mine to turn on (I have to smack it actaully), but once it does it says “Refreshing Database” for about a split second, the bar moves up and then it shuts off. My brother had the 2G (I have the 4) a year or two ago and his did this exact same thing within a month of having it, and sure enough, it’s been nearly 2 weeks with this thing and it’s already having this problem. My only conclusion is that these things are deffective, but I could be wrong and it could be a common error we both made.

I have resolved this entire thing by taking apart my own sansa.  There is a red wire that seems to be defective in all sansa clips.  I used an electrical iron and put it back together.  I had two problems actually.  I was in MTP mode and the wire was not attached.  It would charge when connected but without the positive connection it wouldn’t turn on.  So I got it working, not I need to do recovery mode or something to fix it.  I’m currently making a youtube video on how to fix this problem if anyone wants to check it out.  It should work if you want to venture opening it up.  I even let you know where is the best place to open it up with and with what.  So I hope this resolves it for a lot of people.  I know I was pissed for a while.

Cheers!

Davia (drumsexy9 at youtube  should be up around jan 14th or 15th 2009)

Thanks for sharing your efforts!

Dang, I’m a dead man.  My wife let me use her Clip (I have a fuze) and when I was coming back from the Gym I tried to turn on the clip and it wouldn’t turn on. It has been charging for over 5 hours and still doesn’t show a full charge and immediatly after disconecting the clip from a wall charger it goes dead and wont turn on.  My wife is not going to be happy :(.

I got an RMA, I send in my clip, they will take 7-10 days to ‘process’ my clip and they will eventually send one back.

hey my red wire is disconnected.  What is the best way to strip the wire (it looks so thin), and what is the best way to attach it back to the connection.  Is epoxy cheap? and where could i get some?  (home depot?)

Epoxy!

I think not.  Resin is non-conductive.  The wire needs to be soldered carefully.  If you don’t have the proper tools or experience, see if a friend has some electronics experience.  Then you’ll have a proper repair.

Bob  :smileyvery-happy:

no bud, they do sell conductive epoxy used in place of solder.

i’ve respectivly read all 4 pages as well as other solutions, my screen still goes shot dead after i unplug it

(hold center for 15 seconds while on hold)

(nothing can be added or deleted)

so on and so forth

Likely, then, that the lead to the battery has become disconnected?  If you have warranty left, contact SanDisk?

uhhmmmm  im hoping i do. if it comes in paper form i might. i’d have to look

My 4GB clip plays music perfectly when I plug it into my car charger. And as expected, when I use the USB connection to my computer it shows up as a drive in the “My Computer” window and it syncs with Windows Media Player.  If I right click the Sansa Clip icon I get a serial number, firmware (1.01.18A), and a Battery 100% icon.  BUT - like DANO4266, unplugged from USB it’s dead in the water.  If I put the Hold button on, depress the center button, and plug it in to my PC the Clip ‘hangs up’ and the computer says “Device not Recognized.” 

I opened it up and resoildered the battery connections, and also tested the connection points on the circuit board with a multi-meter.  There is power coming to the battery connection points when the USB cable is connected, but only immediately after I connect.  Shortly thereafter I get no voltage reading.  So, based on the lack of USB power to the connection points and the displays (PC and Clip) suggesting the battery is at 100% charge, I have to assume the problem is either the battery, its circuit board, or both.

Is there a way to reset the battery circuitry?

It you resoildered it (and dont take this the wrong way) did you do a good job? By this I mean were your soilders clean, and small? If they are too large you could have a short.

Alright. I put it in the charger and after a while wen its charged I take it out but wen I take it out the screen goes black and  cant turn it on. I can do everything on the computer but I just cant get it to turn on.

Did your player have a fall recently?  A lead to the internal battery could have come undone.

If i were to attempt to fix this detatched battery lead thing, how do i open it up?

Whats an RMA…?..if i don’t have any of the packaging or reciept am i still able to send in my clip?

RMA is return authorization from the manufacturer/seller.  Usually, a receipt is needed, to prove purchase date.  But you could telephone (that’s best) SanDisk and see what they might be able to do for you.

Various people have opened their players up.  You can try a search here (search box at upper left).  Recommended has been to pry the case apart starting at the on switch opening, using a thin tool of some type that won’t mar the plastic case.