My Sansa Clip is not responding :(

I was listening to my Sansa Clip a bit ago, when it turned off suddenly. It wasn’t the first time it happened, so I figured I should just hold the button down for 15 seconds and it should just restart it self. I held it down…and it didn’t restart. It showed me the Sansa logo, and froze that way. If I hold the start button down, it turns off. If I hold it down again, it shows me the Sansa logo and freezes that way again. And that’s all it will do. I tried holding down the reset button, but it did nothing.I tried connecting it to my computer, but all it does is make the Sansa logo come up and freeze again.

This is a little upsetting. What should I do?

Now I got it to show my music at least, but then if froze :frowning:

And now it keeps freezing. When I press a button, it takes it at least a minute to respond. When the screen goes black like it does when you don’t touch a button for a while,  I hit the home button, but nothing shows up.

Now it’s frozen and not responding at all.

Drain the battery, then plug it into a computer and try to format the drive.