My sansa clip has various issues i think...

ok, i bought the sansa clip today…and i conected it to my pc for about 10 min, then disconected it to test it.
well, it worked at first,but then the battery died…
so i conected it to my pc, it shows “conected” and the battery thingy doesnt blink, it shows it as full.
but when i disconect it it keeps saying “battery low”
i cant even change the to msc mode or what ever (by putting the clip on hold and pressing the center button)
thats not working…
anyone knows whats happening?
help plz.


Sounds like either a bad LiPo pack or failed charge circuitry - it seems the battery monitoring is working when under load though. I’d put my money on a failed battery though as these symptoms point to a high internal impedance in the battery.

Exchange the Clip for another one and you should be just fine.

if you cant force to msc, then you aint doin it rite
hold on , push centre button, plug in at the same time

Message Edited by amkoas on 01-03-2008 07:37 PM

that was the problem
i called the sansa tech support, and the guy told me to do so.
i fixed it
now its charging
he told me to update the firmware so i can change modes, etc.
thanks for the help though.
im happy…

youre welcome