My new Sansa doesn't work in the car

Must you format the sansa fuze before synching music to it?  The user manual shows you how to format, but doesnt say you must format before dowloading music to it.  It does say, however, “formatting will delete all your current content.”!!!  When I connect the USB plug into the device, and then into the car, it says, “no media available.”  However, the old c200 Sansa worked just fine, and I never formatted that one.  I’m hoping its not a formatting issue, cause i spent 8 hours yesterday synching 300 songs to it, and dont want it deleted!!!  I even updated it using firmware!!!  I reset it, and still doesn’t work.

Anyone have any similiar issues, or know of any solutions?

This is not related to formatting or firmware versions.

My guess your USB mode (System Settings > USBMode) is set to ‘MTP’  or ‘Auto’ while you need it to be ‘MSC’ for it to be seen by your car stereo.

However, music copied to the player in MTP mode will not show up in MSC mode so you will have to put the music on it again (i.e. remove it in MTP mode, copy it manually in MSC mode)

What are you using to connect the Sansa Fuze to your car?

Might be the accessory you have doesn’t include the Sansa Fuze as one of the supported device.