my m240 doesnt function any more after got the firmware updated...

i bought the m240 yesterday evening, checked it all, also the instructions and manual books. then i visited here and found the firmware in the link below http://www.sandisk.com/Retail/Default.aspx?CatID=1326
i ran the firmware and it updated. but after all, m240 (with no files in it) tells me that it has no free space (none in use and none usable), also in information section it tells that it has 85 songs and 107 recordings in it. i cant load anything in it. i tried to recover the firmware but couldnt success it too. when i connect m240 to usb in msc mode i saw that it cant be formatable cause when i tried to do that the computer warned that there was no disk in the drive… also when i choose the playlist, t freezes
i think i wiped it out and it became something that i cant fix.

is there anybody having any idea about this case and who’ll help me?

thanks…

heyyyyyy
why dont you give an answer?

If you are unable to format it no matter what you do, its prolly defective. Give sandisk a call for verification.866.SanDisk.

Not being able to complete a format is usually a problem in my book.