my laptop system didn't recognize my clip?

When I connect the clip to my laptop, the screen of the clip shows connected but my computer doesn’t show any new flash disk connected.

I have tried it on other’s English version Win XP2/3 operation system and it works. Mine system is not English.

What can I do with it?

Actually when the clip is connected to the laptop, the flash disk connected indicator sometimes shows on the right bottom of the laptop screen but there is still no new disk in “My computer”…

Who can help me?

Thank you!

Your Clip may be connecting via USB in MTP mode so it will not show up with a drive letter (F:\ or G:\ etc. only show up in MSC mode).

Look for the Clip under the Control Panel (assuming Windows) and under Audio Devices.

If it’s not showing up, you may want to look at the Device Manager (right click the My Computer icon on your desktop and select Properties, then click on the Hardware tab, then click on the Device Manager button) and see if you see any yellow triangles or red exclamation marks (!) to try to figure out what the issue might be.

Good luck and let us know what worked (being optimistic).

Sometimes laptops (having finite power resources) doll out power through their USB ports very ‘economically’. Some people have reported not being able to use their laptops at all for charging or data transfer to their Sansas. They have to use a desk-top computer.

Here’s a few tips. They may work or they may not,  but they’re free so the price is right:

  1. You can try a different USB port (if you have more than one).
  2. Make sure your laptop is ‘hard-wired’ at the time, and not relying on battery power alone.
  3. Make sure your Clip is in MSC mode for maximum connectivity reliablility (makes it easier to connect).

Good Luck! :smiley:

Hi SteveG,

I’ve tried in the MTC mode and it works!

The problem is there are no songs in MUSIC, which I did draw them in the clip before.

But after I disconnected it and open the clip for the music, I could listen to all the songs in the clip.

It is really weird. 

And I tried twice, nothing happened.

Thanks, Tapeworm!

I followed your third tip and it works.

Another new problem comes up as I described in the reply to SteveG…

While connected in MTP mode, you cannot see the songs transferred in MSC mode.

While connected in MSC mode, you cannot see the songs transferred in MTP mode.

Rest assured all the songs/podcasts/books are there.  Most people use the same mode all the time so they can see all their music on the computer without having to change modes from MTP to MSC or vice versa.  Since I listen to a lot of WMA audiobooks with Digital Rights Management (DRM) licenses I use MTP.  If you have DRM-protected WMA files, use MTP all the time.  If you only do MP3 files and non-DRM WMA files, use MSC mode all the time.  Make the choice in Settings… USB Mode… and either MSC or MTP depending on what’s best for you.


Thanks again!