My fuze is frozen during charging!!!

I have no idea why this has happaned, but while charging my sansa, it froze on the screen where it says connected and the arrows are rotating in a circle. My sansa has never had a problem until now. It froze on the charging screen and I tried letting it cool, replugging it into the computer…everything.

Does anyone possibly know how to fix this problem? I just got this like less then a month…and its messed up. I’m pissed.

Try holding up the power switch for 20 seconds.  Then restart the Fuze.

Message Edited by SansaMe on 07-15-2008 09:07 AM

Wow, that definitely solved the problem!

Maybe I didn’t hold it up for long enough.

Anyhow, Thanks so much–it is working perfectly again! I probably overcharged it or something, if that’s even possible. 

Thanks you!

All that happened was the processor halted.  The soft reset is your friend!

If your Fuze ever appears to be playing possum, or won’t respond, the simple reset works wonders.

Bob  :stuck_out_tongue: 

The same thing Happend to mine but it was stuck on the diconnected screen. Im letting cool down now before turning it back on

i had a video froze on me and i got white screen, but a soft reboot for 20sec fixed it :wink: