My Computer found my Clip!!!

When I first connected my Clip to my computer it worked fine.  I upgraded the firmware.  Then I put a couple of songs on it.  Later on, I attached it to my MacBook for fun.  Anyway, yesterday when I connected it to my PC with the USB setting on auto, my PC couldn’t see it.  I couldn’t put an Overdrive book on it because it couldn’t find it.  The computer could see it if I changed the USB setting to MSC.  But MSC won’t work for Overdrive books (and other things, I’ve found out from reading this forum). 

ANYWAY, I fixed it today.  On Microsoft’s site, after reading in the “Readme for Windows Media Player 11 for XP”, under the “Device not recognized after installing WMP 11”, I decided to try “uninstall the device in device manager”.

Even tho using Explorer it looked like my device wasn’t connected, it was in the device manager list.  So I uninstalled it, and restarted my PC, then reconnected my Clip and now my PC sees my clip.  YAY!  I hope I can now transfer my Overdrive book!

Here are the directions from Microsoft:
You must be logged on as an administrator or a member of the Administrators group to perform the following procedure.
Turn on your device and connect it to your computer.
On the taskbar, click Start , right-click My Computer , and then click Manage.
In the pane on the left, click Device Manager.
In the pane on the right, expand Portable Devices.
Right-click the name of the device that is not working properly, and then click Uninstall.
In the confirmation dialog, click OK to uninstall the device.
Disconnect your device from your computer, make sure it is still turned on, and then connect it to your computer again.

Windows will detect your device and automatically re-install it. Within a minute or two, the device name will reappear in the Portable Devices section of Device Manager.

thanx for confirming what is posted here daily… the device manager > uninstall/ reinstall…

Thanks for posting the steps to follow, in case they are needed and as a reminder.

Well, Sorry!

I searched this forum for hours yesterday, and tried all kinds of things like using MSC, reformatting, making sure I had WMP11, downloading something about MTP, and I never saw anything about uninstalling in the device manager. It may be posted daily, but I didn’t find it.

Maybe my post will help somebody find the answer.

My Overdrive book works, btw.

Message Edited by kcm77 on 01-01-2008 05:27 PM

i aint baggin on ya dude,  good job… sorry you came up blank in yer search but its there

Message Edited by amkoas on 01-01-2008 03:41 PM

good to hear that you got your clip working again :smiley:

Its always fun fixing a problem :slight_smile: