my clip+ 4gb suddenly bricked after copying some songs from the pc

I have my clip+ 4gb for about 6 years, and i copy songs to the microSD card via usb. Some days ago I have copied some more songs and left it connected to charge its battery through the night. The next morning i have disconnected it from my laptop and noticed that it takes too long to “update the library”. Then it finally turned off, never to be turned on again… 

When i try to turn it on, it either loops sansa logo and the flower, or it just keeps stuck at the flower. 

Then, about 20 minutes later it turns off by itself.

I have tried:

*connecting it to the pc. it does not show up as anything.

*resetting by holding buttons, i have tried many combinations and does not work.

*removing the microSD card.

However, holding the power button for ~15 seconds during the loop turns off the device. This is the only response i got from it.

Is it completely a brick? Or is there still a chance to fix it? I have looked up the internet but could not find anything to help me.

Thanks in advance.