Multiple C250 problems :-(

i just bought the Sansa c250 2GB version and i am experiencing some problems:

  1. When i plug the player to the PC in MTP mode, the device is listed as “unrecognised” and restarting doesn’t help. (I have windows XP).

  2. In MSC and MTP mode, the player doesn’t charge.  (Isn’t the battery indicator supposed to indicate that it is charging?)

  3. The down/option menu button doesn’t work!

  4. When plugged to the PC, the player freezes…both MSC and MTP modes. Also when unplugged from the PC i have to turn the player OFF then ON because it is still unresponsive.

  5. Tried a firmware update…it is still the same.


wow, if it does all that everywhere you take it then give sandisk a call. They will probably replace it. 866.SanDisk is the number.

How long ago did you buy the player? If it’s fairly recent (within the last 30 days), I’d bring it back to the store and get another one. Some of those sound like they could just be computer conflicts, but if you’re still within the return policy for where you bought it, just exchange it out for a new one with all the buttons working.

Otherwise, definitely give tech support a call.