MP3s won't transfer from music folder

I just got a Sansa Clip G2.  I use a Mac.   I had a Sansa Clip that I lost which worked fine.

I made sure it was on MSC mode.  I upgraded the firmware via my Mac and also reformatted the Sansa per instructions from support.   Still not able to transfer MP3 files from Music Folder to the Clip.   

I hooked it up to my husband’s PC and downloaded the firmware from there like you used to have to do.  This also was recommended by support.

Followed all the instructions.   Still no dice.

Anyone with a solution?    :angry:

Thanks so much.

Rita

where is your music folder? if you are talking about itunes i dont think you can drag directly from the itunes software to the clip+. you will probably need to go to the actual folder where the mp3s are stored and drag them from there to the clip+

Have you checked the USB mode under the Clip’s Settings/USB Mode recently?  The reason I ask is, when you reapply the firmware, the USB Setting gets re-set to Auto.

Hi:

I have always dragged my mp3 files out of iTunes into the Sansa Music folder with  no problem.   This evening, after I posted, I dragged a third mp3 file out of iTunes and it worked!!!   I’m not sure why the Sansa is being so picky but at least it worked. 

Thank you for your input.

Rita

Yes, I noticed that and changed it back to MSC.  Thank you, though.

As stated to the other poster, some of my mp3’s are actually working now, but not all.  It didn’t used to be that way with my other Sansa Clip.  But at least I’m getting somewhere.   Thank you for your response.

My hunch is then, it has to do with iTunes, which is infamous for complications when used outside itself.  Good luck!

Sadly, you’re probably right.  Thank you.

Rita