"Missing media usage rights" files won't sync?


I am trying to sync sound files to my Clip+. Most sync OK, but some (many) will not. The result is the same whether using Windows Explorer to drag and drop the files, or using Windows Media Player to sync them. (I am running Windows 7 Ultimate and Windows Media Player 12.)

I believe the problem is related to usage rights. In Windows Media Player, when I view a sync report, right-click on a problem file anc select Propertes, under the Media Usage Rights tab this message appears; “This file is missing media usage rights”. Files which have synced successfully show “This file is not protected”.

Windows Explorer cannot identify the problem files. It simply shows that no files are protected. MediaMonkey is also unable to identify these files when an appropriate script is run.

I am able to overcome the issue by using Tunebite to copy the file, but Tunebite’s auto-search for DRM-protected files is also unable to identify the problem files.

Does anyone know of a way that I can automatically identify the problem files so that I can place them in one folder and quickly run Tunebite on them to fix the problem? I would very much like to avoid having to manually select each file. (I believe I mentioned that there are LOTS of them!)

Any advice would be appreciated.

Thank you.

Are these WMA files? MP3 files have no protection. Some WMA files might be protected. Protected files need to be transfered using Windows Media Player or some other Media player that is able to transfer licenses. Otherwise the player won’t play them.

Thank you for your quick reply.

No, these are all MP3 files. They won’t transfer using Windows Media Player, MediaMonkey or Windows Explorer. It is always the same files that fail to sync, no matter how many times I try.

It seems a little strange to me.

Any ideas will be welcome.

Thank you.

MP3 files are never protected. I never sync files. I use Windows Explorer to copy and paste folders of files to my players.

instead of dragging and dropping the files to the player, try using Windows Explorer, and copy and paste folders of files to the player.

If you try moving files using Windows Explorer while they are open in Windows Media Player, they won’t be moved. 

Thanks for the suggestions guys. Unfortunately, however, none of them work for me.

No matter what method I use in Windows Explorer, even after a reboot of the computer with Windows Media Player not started, the transfer of the problem files fails.

From my research it does seem to me that the problem lies with the media usage rights. Whenever a file displays the message “This file is missing media usage rights” it won’t sync/copy.

I have seen suggestions that this message can occur following a change of CPU. I have definitely changed computers since these files were originally created so that might be related to the problem.

The actions I have seen recommended as possible solutions haven’t worked for me. The only thing that has worked has been to use Tunebite (which can legally remove protection by copying the original file). After running Tunebite on a problem file the media usage rights message reads “This file is not protected” and I can sync it correctly with the Clip+.

Unfortunately - unless anyone has any other suggestions - I may have to run Tunebite on all my music files. That will be pretty fiddly and time consuming if I am to preserve my setup.

If anyone has any other thoughts please post them.

Thank you.

Is your player set to MTP for the USB mode? MTP is often problematic. If so, try setting the USB mode of your player to MSC. Settings, system settings, USB mode>MSC.

Are you really sure they are mp3 files? Is your windows set to un-hide extensions of known filetypes? (Look for “Hide Extensions” in Help.) 

It sounds like you (or whoever)  ripped those files with copy protection on a different computer.  As noted, mp3 doesn’t have copy protection, so it would be very odd for those to be mp3–though I guess anything is possible.

The default in Windows Media Player for a long time was .wma files with copy protection. That protection  is tied to the ID of the old CPU.  If it’s a file that was set to use WMP as the default player–mp3, wma, .wav–then it would show the same icon. 

If you can play the files in WMP on the computer, your best shot is to put the Sansa in MTP mode (Settings/System Settings/USB Mode) and synch them over via WMP. That will send unlock codes if it’s possible to send them. But there’s all kinds of copy-protection junk, including codes that only allowed a limited number of transfers, etc. If sync from WMP won’t work, you’re probably stuck with Tunebite. 

Make sure your default ripping setting going forward is .mp3. Media players (iTunes, WMP) tend to bury that default choice, but click around settings or options and you should find it .

Thank you for all the advice.

I am very happy to report that the problem now seems to be solved.

I am not sure what exactly fixed the issue, but here is what I did immediately prior to carrying out a successful sync;

1/ Following information found elsewhere I navigated to C:\ProgramData\Windows\DRM and deleted the contents of that folder.

1/ I set the Clip+ to MTP mode as advised in this thread.

3/ I re-created the playlist from within WMP.

4/ I synced from WMP (as advised in this thread) and all was well.

Thanks again for all the help. It is much appreciated.