Microsoft Windows 7 USB download just broke it

Sandisk Cruzer 8GB

I’ve just tried to install Windows 7 on my new desktop after using the Microsoft Windows 7 USB DVD download tool.


(And yes I do have a genuine legal image so it isn’t the Windows 7 image which is causing the problem)

Everything seemed to go well - said it copied and completed correctly.

I inserted the drive in the PC, choose to boot from it - but go the error message NTLDR is missing.

Thought I’d try again.

Put it back in the laptop and restarted Windows download tool - received the error message to the effect of some other program is using it - which must be closed first.

I rebooted the laptop and tried again.  Same error message.

I then gave up and thought I’d try formatting the drive (with the possibility of restarting the process - but thought I might just go for the dvd option - problem is no blank disks at home)

Windows tried to reformat to 16mb then said it couldn’t

I then tried the HP tool which similarly claimed only 16mb and again failed to reformat.

Anyone got any ideas.

Greatly appreciated.

I inserted the drive in the PC, choose to boot from it - but go the error message NTLDR is missing.”

The ISO file you downloaded needs to be burned to a DVD or  “burned” onto a USB.  The downloaded file is not bootable directly.  Reread the instructions.

“If you choose to download an ISO file (so that you can create a bootable file from a DVD or USB flash drive), copy your Windows 7 ISO file onto your media and, run the Windows 7 USB/DVD Download Tool. After you do this, you can install Windows 7 onto your computer directly from the USB flash drive or DVD.”

You did the 1st part, the copy, but not the 2nd part, the run the download tool.

" thought I’d try formatting the drive"

Deleting a file is so much faster, and safer.

Anyone got any ideas.”

At this point the state of your USB drive is questionable.  You may need to acquire a replacement.  And the Windows 7 downlad didn’t break it, what you did, or didn’t do correctly, (may have) broke it.

No I used the Windows 7 USB DVD software to burn the iso to the drive, the problem was that after that the drive didn’t recognise at all - that is when I tried to format it to get it back to a functional drive.

However, I have managed to recover the drive - I used a mac to format it - curiously enough the mac had no difficulty in seeing all the files on the drive either!

So for others with similar problems one possible solution may be to try using an apple mac to format the drive.  After formatting with the mac the drive worked perfectly again


I’m now doing the stupid thing - I’m going to retry!

The windows 7 USB software currently reads at 50% files copied!

Will I report success or failure within the next 15 mins remains to be seen!

Just for the record - my retry failed.  The sandisk wouldn’t allow writing to the boot sector - however, I have successfully used a blank dvd rw  and the sandisk is working happily as a drive again.

Adios, and thanks to all who took an interest.

I am very happy to hear that things worked out for you.  :smiley:

But I don’t understand how sandisk could prevent an app writing to the boot sector.

  1. Sandisk is a drive, composed of bits, bytes and clusters.  No software.

  2. The only difference an app writing to the drive may encounter is whether Windows considers it to be removable or not.

  3. The boot sector is simply a cluster with a low number, though important for booting not particularly different than other clusters.

I would love to see an screen print of the error msg you encountered. 

Glad things worked out for you and thank you for posting your update…