Micro SD problems

Hey everyone,

i just, today, got a Sandisk Micro SD card for my Whitetail Game Cam and my Sansa Express, it came with a SD converter.

I put it in my mp3 player, turned it on, and after it finished “building database” it just shut off i tried it many times, it only worked once,

and when i put it on the converter and put it in my cam, it said “card locked”, so i figured out how to unlock it but it would only work half of the time,

did i just get a faulty chip or are these cards just not good overall.

thanks to anyone with a reply that’s helpful


I own a few of those cards and they’re rock-solid for me.  Can you elaborate on how it only works “half the time?” Some devices are flaky by nature, or have trouble working with 2GB cards, or SDHC cards (depends on the exact device and the exact model of card you own.)

For getting it to work in the Express, you can try formatting the card, that tends to help quite a bit if it’s acting strangely (and you only need to do it once.) Formatting the player as well isn’t a bad idea if the issues persist (wipes the database clean.)

well, when i put it in my camera it says locked, i try again, and it says locked, i try again and try to put it in thoroughly, if you know what i mean, it might work, i try again, it says locked, when it works it say Pictures: 0000/8652 which is right, but i can only get it to work sometimes, i don’t know if its just the little adapter though you know, or maybe i have to do something on the cam, but a problem like this must just be one little faulty adapter

PS: i figured out my Express, i just needed the 01.01.05 firmware now it works like a dandy

So it works fine in the Express but not in a card adapter in your camera?

Have you tried cleaning the contacts on everything, especially the adapter?  The fact that you said that it only works when it’s pressed in “thoroughly” makes it sound like there’s something on those contacts.  Could be dirt, could be oxidation, could even be a protective film of some sort.  Rubbing alcohol and cotton swabs (moistened, NOT dripping) works wonders.

well, i tried cleaning it off with a wet cotton swab, and it now works about 90% of the time, but i don’t know whats wrong with that other 10%, it just says card locked, but it works good enough to not bring it back now,

thank you so much, if you come up with any other info of what might be the problem please tell me

once again, thank you very much,

God bless you, and he loves you more than anyone else possibly could



In my opinion, “good enough” is not good enough.  Try cleaning the contacts on both the card and the adapter again, if you didn’t use alcohol the first time, please do try it this time…  and if you still can’t get it to work right 100% of the time, call SanDisk.  You paid good money for the card and they have a vested interest in seeing to it that you get your money’s worth.

i tried it with rubbing alcohal and it works every time, thank you so much, you saved me alot of time and energy,