micro cruzer + windows 7

I have successfully used my micro cruzer with the U3 Launchpad software for a couple of years now on my computers running XP.  In December, I recently bought a laptop that runs Windows 7, and up until March or so, I had no problem using the drive with the u3 software in the new laptop.  However, since March, whenever I inserted my drive into the Windows 7 laptop, Launchpad tries unsuccessfully to start (I get the “Initializing …” notification, but that’s all that happens).  When I insert the drive into an XP computer, everything works perfectly, so in order to use the drive in my new laptop, I disable my password (needed on the drive) on an XP computer, use it as a regular flash drive on my new laptop (running Windows 7), then reinsert it into my XP computer to re-engage the password.  I would like to get the drive to work again under Windows 7. 

I tried updating the Launchpad software using my XP computer - I am running Launchpad, with device version 3.27.  I tried compatability mode (XP SP2 and Vista SP2) with the same results - “Initializing …” and nothing else. 

I’d appreciate any help!

Does this thread help?  http://forums.sandisk.com/t5/Cruzer-flash-drives-Solid-State/Pass-protected-cruzer-not-accessible-on-win7-and-xp-Any-help-is/td-p/186623

Nope - if I am interpreting that thread correctly, his cruzer doesn’t work in BOTH windows 7 and XP; mine doesn’t work in Windows 7, but DOES work in XP.  I also updated the software and drivers on it so I have the latest versions.

Thanks anyway!