Merged MP3 file causes Clip to reboot

I’ve been using MergeMP3 to merge ripped audiobook files for years with no problems on my ancient Clip. Every couple of years I get a new bunch of audiobook CDs from the library, and this year I did everything the same as I’ve done in previous years. However, regardless of how many or how few files are merged, the Sansa reboots and refuses to play the merged file. It will run each unmerged file just fine.

I have tried everything. My tagging is complete (using Mp3Tag) for the individual files, and I also tagged the merged files. I’ve factory reset the Clip. I’ve updated the firmware. I also tried a merged MP3 on a brand-new Clip (yes, I have 2 brand-new clips that I’ve held in reserve for years). Same problem. I have to soft-boot to get it unfrozen and then delete the file using my computer to access the Clip.

As a test, I loaded a merged file that I created last April and had successfully listened to on my Clip, but now THAT file won’t load either.

I’m pretty sure this isn’t a problem with the MergeMP3 program, but just in case it was, I installed an older version of MergeMP3 on my laptop, merged a few audiobook files, and tried THAT on the Clip. Same problem. There is no working email address for, the developer for MergeMP3, so I cannot contact them to get their ideas. ( bounces and their online contact form fails to send a message.) But I’m pretty sure this is a Clip problem, not an MergeMP3 problem.

I know this is an ancient MP3 player and I can see that no one has used this board for a few years. But I’m hoping that someone has some new ideas for me. I’ve spent 3 days now trying to solve this problem and am out of ideas.

I used “mp3merge” a few times in the past. Seemed to work OK for me to construct an mp3 file that was about 1 hour long.

I used ~18 mp3 files encoded at 192 kbps (using my Clip Sport).  I can guess it is not good to merge mp3 files with different compression settings.

I can also guess the Sansa players cannot handle mp3 files that are longer than ~2 hours ??


ALSO, the Help instructions inside “mp3merge” describe the add-on utility “iTunesEncoder” to convert mp3 into M4B files (iTunes book files).  I can guess the Sansa players may choke when asked to play that type of file. AND maybe the Sansa will choke when attempting to add M4B files into the Music or Audiobooks or Podcasts databases.  (May need to delete those from your player & SD card.)

      My current best advice (?), is try merging a few (3?) known working mp3 files into a larger mp3 file. Then check the ID3 tag data. Then try to get this test file working on your Sansa. Then proceed making larger merged files from there. Maybe report back here with your discoveries?

Thanks, DFELD2005, for your thoughtful response. I had already systematically tested every conceivable tag setting(s) and also determined that it didn’t matter how many files were merged. Even two small files, each about 5 minutes long, when merged using MergeMP3 failed to play in either of my two Clips. The individual files played fine by themselves. The files that I’m loading into the Clip are all mp3 files; no M4B files exist.

The files were all ripped using the same settings in MediaMonkey, so I don’t THINK there is a difference in compression settings. I did have to re-tag all of the files because MediaMonkey was very inconsistent in tagging (odd, since I changed nothing between inserting one CD of an audiobook and then inserting the next one).

This is a head-scratcher for me. The last time I did a batch of library audiobooks using MediaMonkey to rip and MergeMP3 to merge was in 2012 and I had zero problems. But things in 2018 are different. I’d wondered if maybe there was some DRM setting that was interfering, but if so, the individual files should be affected, not just the merged files. I experimented with an online merging service and those merged files play fine, although the audio is diminished. I suspect that the service re-encodes (which triples the file size). But that makes me wonder if MergeMP3 is putting something in the header that the Clip objects to. A merged file using a DOS command prompt plays fine, but the Clip can’t resume where it left off because (so I read) there is no header. There is no working email address for MergeMP3 so I can’t email to ask them this critical question.

Can anyone recommend a software program that merges MP3 files that the Clip gets along with? A program that they actually have used within the last year or so?

Here is an alternate suggestion for enabling the correct, logical playback of ripped Audiobooks using Sansa players.  This method works well on my Clip Sport(s).

Thanks again, DFELD2005. I had already figured out the best way to tag my MP3 files so that they sequence correctly on the clip. My question was not about tagging, it was about how to get files that are merged using MergeMP3 to play at all. They are all tagged correctly. They simply will not play; the Clip reboots as soon as I select a merged file.