Hi I purchased a sansa clip about two monts ago and now for some reason it just has malfunctioned im not really sure what to do but if someone can help me it would be really nice

Unless you give some more info now one can help you. What kind of malfunction? What were you doing whn this happened? If its related to your computer we need to know the operating system, and the service pack. If you clip is working Check to make sure you have the latest Firmware, and If not post what one you do have.

well when it first malfunctioned i was putting music on it and the screen just wnet away but it was still working and that was about a month ago. But now just last week i went to go turn it on but nothing popped up, so i wasnt sure what had happened. And i dont know what kind of firmware it is.

Try restoring your Clip via a soft reset : slide the power switch to the ON position, holding it there for 15 seconds, release, then try powering up as usual.

Plug in your Clip, and see if it responds when connected to the USB port.


well i’ve tried that plenty of times and it still seems to not be working, like nothing is popping up

Okay, let’s try one other thing.  Start with the Clip OFF, and slide the power switch down to the HOLD position (orange showing).  Press and hold the center button while plugging in to the USB port.

This will force a manual MSC connection.  See if the Clip responds in this mode.

If not, you can contact Support at 1-866-SANDISK for further assistance with your Clip.  They have a one-year warranty.



Message Edited by microsansa on 03-09-2009 11:18 AM

well i’ve tried that to so what im gonna do is just tyr to call the support and ill let you know what happens