mac-osx won't read 32gb sandisk cruzer-glide …

short  version … mac-osx  does  not  read  fat32  usb-drive.

read  below  for  extrapolation.

32GB SanDisk Cruzer Glide USB Device (USB (SATA-II 3.0Gb/s))
win-10 (1703-15063.483)
mac-osx (10.6.8)

mac-osx  won’t  read  32gb  sandisk  cruzer-glide …

had  worked  great … could  play  music  on  usb-drive  in  my  car … could  read/write  both  mac/pc  platforms … the  world  was  good.

two  days  ago,  tried  copying  a  4.2gb  file  to  the  usb … fat32  cannot  cope  with  anything  above  4gb.  the  way  around  that  was  to  convert  fat32  to  ntfs … used  command-line  for  the  conversion.  usb  now  was  using  ntfs  and  had  no  problem  with  the  4.2gb  file.

one  day  ago,  tried  playing  music  on  usb-drive  in  my  car … wouldn’t  work.  i  reasoned  to  myself  the  drive  needed  to  be  converted  back  to  fat32  as  original.

researching  this … easy  converting  fat32  to  ntfs … slightly  more  challenging  other  way  around.  internet  stated  two  options:  either  reformat … or  use  third-party  conversion  tool.  so,  i  chose  “Convert NTFS to FAT32”  software  by  macrorit … and  the  conversion  was  successful.  afterward,  checking  pc  “properties” … stated  the  file-system  was  now  back  to  fat32 (as original).  also … usb-drive  played  music  in  my  car.  once  again … the  world  was  good.

however … now,  when  trying  to  access  files  on  mac-osx … error  appears  “the disk you inserted was not readable by this computer”.

so … in  the  beginning,  cruzer-glide (fat32)  could  read  on  mac-osx … and  now  it  does  not.

      • haven’t  noticed  sandisk  offering  driver  downloads  for  their  usb-devices … so,  guess  i  cannot  go  back  to  original  state  with  software  that  came  with  the  usb?
      • i  could  probably  reformat  the  usb-drive  completely … but  that  would  wipe  out  the  security  programs  that  came  with  the  device.
      • exfat … would  that  be  an  option?

p.s.  i  have  not  utilized  the  secure-access  pw  stuff … so  there  should  be  no  interference  with  that.

p.p.s.  i  do  have  speccy … in  case  you  require  add’l  specs.

I suggest backing up all the files on the drive, then try formating it as exFAT using Windows and see if the car and MAC can handle exFAT.  If a problem with either you will have to decide which is more important to you, exFAT for large files or FAT32 for compatibility.  And if necessary reformat back to FAT32 using Windows.

Reading car/MAC documentation also an option.  :wink:

was  afraid  of  that … thanks  for  the  references,  edp … will  try  the  exfat   this  weekend … else  fat32   will  be  final  option.