M4A troubles.

I have a few M4A’s that used to work, but now refuse to play. They still work fine in WMP, and Quicktime. They also seem to play nice in Rockbox. I have tried to retag with ISO 8859-1 with MP3Tag, but that didn’t do anything. Also, there are no unusual tags present, just Artist, Album, Year, Title, Track, and replay gain. Just for kicks I decided to use MP3Tag to web-optimize the files, as that sometimes helps with mp4 vids, but that made no difference at all. I also tried deleting all of the .dat files and .idx files off of the player, incase one has “incorrect” info about these files. No dice. I found a program that’s supposedly able to fix corrupted m4a (Media Fixer), so I though I might give that program a try. It (literally) did not do anything, as the files had the same SHA-1 checksum before fixing as they did after.

Now, a little more about what’s going on: the files always show up in Windows Explorer, regardless of which mode I use. They just don’t show up in any of the player’s menus (not even in folder view). Just for the heck of it, I decided to remove these files completely, and resync them with WMP (Windows Misery Player). After which they did show up, but when I tried to play them, the player started lagging much more than usual, and I could catch small glimpses of an error which read “unsupported format”. Then, when I deleted the idx/dat files again, the album dissappeared agian. Eventually I got frustrated, and removed ALL of the tags from one file. It still didn’t show up in Folder View.

Any other Ideas I could try? I’d prefer not to convert these files if possible.

Try remuxing with YAMB. It won’t re-encode the audio. Then rename the file extention from .mp4 to m4a. 

Sounds logical. I’ll have to try that.