m260 not recognized on XP SP2

My M260 plays the music it has with no problems, but I can no longer get to the device from a computer to change the content.

It is in MSC mode.

I have tried it on 3 different XP SP2 computers, with the same result:

When I connect the device, the device reads ‘Initializing’

The computer recogizes that there is a new device, and begins it’s plug and play routine, but winds up with ‘USB Device Not Recognized’

At that point, the player appears to be in a normal play mode, with a song title scrolling across the bottom, and and indication of it’s paused state.

The device appears under ‘other devices’ on the PCs, with an exclamation point, indicating that it’s not quite right.

When I plug the device into a Windows 2000 machine, I get a completely different (although no more functional) result.  The computer recognized the device, and I can see it as a drive in Windows Explorer.  The content, however, is not there.  There is a single voice recording, and a few system folders, but my 2gig worth of media files is no where to be found.

Any thoughts, anyone?


Have you tried formating? This will erase all your content. How long have
you had the unit?

Click Here for User Guide and Videos

After replacing the cable, I finally got the unit to recognize on my XP system.  After a number of attempts, I was also able to get my collection off of the device, and get the device formatted.  I was also able to update the firmware to the latest version.

But now it seems that the device will only stay connected for a few seconds after initialization before it appears to lock up.  I was able to transfer about half a song before it locked last time… my best results yet.

Anyone have any ideas, now?

If you don’t get any ideas here you can
write    support@sandisk.com

They will get back to you within a day or two.