m250 file sorting problem - tried everything


I have what appears to be an unusual problem with my m250 player that has yet to be encountered on this forum (I think).

My device plays songs in alphabetical order no matter what I do, period.  I’m using WMA11 and all songs have been ripped using WMA11 in standard 128k (WMA, not WMA Pro) off store-bought CDs and the file names all have the correct format, ie. “01 song.wma”.  I then sync the complete albums using the correct procedure, and on separate attempts have also tried the drag and drop approach with the same results.  When playing music I’ve tried “menu->play music->artist->play all”, also by album instead of by artist, also selecting the first song instead of play all, standing vs. sitting, and just about every other combination you can imagine.  Nothing works.

The odd thing is that when I erase all music and then do a new sync, whatever album is loaded on-screen first will play in the correct order THE FIRST TIME but after another album is selected everything (including the first loaded album) reverts back to alphabetical sorting.

I also have a M230 and I have none of these mentioned problems and all loading and playing procedures were identical.  Everything is peachy on this machine.

My M250 (the problem machine) came from the factory with the latest 2.2.5A firmware so I can’t upgrade the firmware in an attempt to resolve the problem.  Is there a way to wipe this machine clean and start over, or should I try to return it to sandisk, or is there another suggestion?  Could the fact that I have communicated with two different players on this computer (M230 and M250) be the problem and if so, how to I rectify the problem?



Hmm, try a cd in MP3 format.  Since ur riping in WMP does WMP detect it as a legit cd and get you all the information regarding the track? Album/Artist/etc?

try to format in WMP as well.  Couldnt hurt!

Thanks for the reply.

1.  I will try the MP3 format suggestion tonight.

2.  All CDs (100+ from different companies) are detected legit and album info is automatically loaded

3.  I tried WMP already and it doesn’t work - WMA works

4.  Again, everything works great on my m230 - only difference is device and firmware

5.  Any comments on if/how I can wipe this device clean and load new firmware?


Still no resolution on this problem.

Is it possible to wipe out and reload the firmware?  Is this a good idea?

Should I contact sandisk for a replacement?


thats good that it detects the cd… that enables WMP to do the id3 tags automatically for you.  Have not seen on the forums the ability to downgrade the M200 fw :frowning:

Problem solved.  I switched the USB setting from MSC to Auto Detect and everything works fine through MTP mode.

So contrary to my post title I guess I didn’t try everything :slight_smile: