M240 constantly saying "Sync Notice" when trying to play music

I’ve been using Ruckus.com with my M240 successfully for over 6 months.  While Ruckus has its own player to download subscription music files, you have to use Windows Media Player to sync with the player.  It seems to sync fine (no error messages), but as soon as I try to play the file on the M240, it just gives me this notice:

“Sync Notice:  To continue listening to your subscription track, please sync.”

The only thing I can think of is that the internal date/time components on the M240 are hosed and it keeps thinking that the files are past their 30-day mark.  Is there any way to view and/or reset this on the Sansa?

Thank you!


formatting in MTP (Auto Detect) mode with WMP will restet the secure clock. you will need WMP 10 or higher. hope it works

Message Edited by drlucky on 08-02-2007 05:48 PM

Thanks for the suggestion.  I’ve tried the formatting option a couple of times w/o luck, unfortunately.  I have a request logged with Sandisk, too, and will post the eventual resolution.  I’ve also posted a request to the subscription service (Ruckus.com) to make sure the files I’m downloading have sync rights (I’m paying for it, at least!).  :)   I would assume that WMP wouldn’t let me transfer the files in MTP mode if they didn’t have the right, but…

I found it difficult to use WMA music file extension on Sansa m240. After moving music files (wma) to sansa I would get a “Sync Notice”. It wasn’t until I deleted the wma files from my Windows Media Player 11 and then Ripped the album in an MP3 format that I was able to move the music from my computer to the Sansa without that darn “Sync Notice” from appearing and then turning off the player.