m230 corrupted memory


I bought my m230 about three and a half years ago but for almost two years I hardly used it because I don’t listen much music when I’m on the move any more and when I do, I use the cell phone.

Now when I was cleaning up drawers in my room I began checking it out. It starts up and goes in play mode showing many songs available. I can go left and right through “songs”. When I try to play any of them, it doesn’t do anything and I can’t jump through “songs” any more. But menus still work fine.

Then, I plugged it to the computer. The computer detects it pretty fast, I can see the removable drive (MSC mode, MTC doesn’t seem to fire up, although I checked “Automatic mode” in the USB menu) and I can see the folders inside. In the past, I put all my music in a separate “Music” folder. In that folder I had subfolders which are in various “states” of corruption. Some subfolders don’t open at all (windows throws errors), some open but I can’t do anything with the files in them (corrupted), some of them were “good” and I could delete them. All in all, the “Music” folder can’t be deleted.

I tried formatting the drive: Windows gives me errors that the operation could not be done, Linux (Ubuntu) just hangs. I tried running chkdsk. The windows-mode chkdsk gives up pretty quickly. I fired up Windows Recovery Console, as I knew its chkdsk does a better job (I recovered partitions I had lost hope for with it :slight_smile: ). The thing is, that chkdsk gave me a little more insight (gave a few lines about file system errors) but ends up quickly saying it encountered unrecoverable errors on the drive. (Even with the /R switch -> the one for searching the bad sectors).

Then I thought about partitions… Windows didn’t let me do anything with the FAT16 partition of the flash drive (computer management console), Partition Magic doesn’t even consider it (no drive appearing). Using Ubuntu disk utility, I had either device errors, either freezing of the utility. Gparted could never finish the scanning of devices when the m230 was plugged in. Even more, the Ubuntu on my laptop just went crazy after messing a bit with m230 in it. It got to the point where it stopped responding.

It’s a pity there is no direct access to the flash drive entire memory in order to repartition it, repair MBR or so. After the repair, the player could have run a routine to reformat a memory for usage (just like a phone does with the SD card).

The interesting is that at least part of the memory still works. The config files are not corrupted, neither the Recordings folder. The recordings can be played. Files can be copied although I didn’t tried it too extensively.

I thought that, oh well, maybe I can just play new files and forget about the corrupted ones. But the thing is that the library on the player is messed up as well. All I can find listed there is the same song repeated around 15 times. And it won’t even play back.

So… what do you think? Did the Sansa lose any hope or are there other things that I can try? Thanks in advance for suggestions.