M200Plus - UNDEF ??


I have a Clip+ which died. I tried all the tricks in the book (forum) and nothing worked so far.

It doesn’t work at all or show any sign of life when disconnected, however when connected to the PC it shows up as M200Plus and then installs as UNDEF. The UNDEF is recognized as unformated and cannot be formated by Windows.

I found a threaddiscussing this situation for the e280 which can be fixed with the e200tool. However, I did not find such a tool for the Clip+ and won’t want to brik by Clip+ all together by loading it with the wrong firmware/driver/bootloader.

If I understood this correctly this e200tool is actually created in Linux. I did use Ubuntu a little, but am pretty green on it. I’d appreciate someone helping me along with this.

Any other sugsetions will also be appreciated greatly.


Perhaps the information here can help out: http://www.rockbox.org/wiki/SansaAMSJTAG

It requires soldering though, I don’t think there’s a software-only way because there’s no “rescue mode” on the clip+ like there is on the e200v2.

Message Edited by 7o9 on 05-06-2010 09:21 AM

Message Edited by 7o9 on 05-06-2010 09:21 AM

The Clip+ hasn’t been out that long, so it assuredly would still be under warranty. I would take advantage of that. Call Tech Support; they can arrange warranty replacement if they can’t get you back up & running.

Don’t think I’d mention the Rockbox thing though. :wink:

Thanks for your replies guys.

I am not technical enough to try the soldering, so I’ll see what Sandisk has to say about it.

Thanks again for your efforts

Definitely go back to SanDisk under the warranty before trying to fix it yourself.