low audio

1st off wanna say I love Sansa mp3 players. This is my 3rd one. And this is my 1st time with a possible neg. I guess I’ll get straight to the point… the audio sucks.  I put the volume to MAX… I have the EQ to FULL/High… and yet it sounds like a tin can.  wtf.  I tried to relay gain… I cant figure it out. I put it to 12 and nothing to 0 and same… so just left it.

Am I missing something??  I have tried headphones and car piece. All the same, my last Sansa player was 10 times better with audio.

Did you set your Region to Europe?

http://forums.sandisk.com/t5/Sansa-Clip-Sansa-Clip/No-more-High-setting-in-music-volume/td-p/143062

My guess is, the above should do it–setting the player’s region to U.S. or Rest of World, rather than Europe (which limits volume).

Also, however:  do make sure that the headphone plug is inserted fully.  When Clips are new, the headphone jack can be very tight–very.  Necessitating a firm insertion of the headphone plug the first time or 2. 

I’ve seen someone with the issue. IF region settings does not work for you and if you’ve verified the volume control at the side, might as well try a firmware update. 

I’m surprised this doesnt get louder. the other one I had even had a volume limitation you could set if too loud lol.  the Region did make it louder but still not as loud as I was hoping.  still a improvement at least. I gotta hope I dont lose it now lol. I can with stand the currently lvl for now at least.  Thanks.   Still rather sansa over ipod… best mp3 players that I have had and i have gone though a few of them

Do you have the Volume setting on HIGH? Not the volume rocker on the side, but rather the setting in the Settings menu?

These things put out major decibels, unless you using some awfully high impedence headphones.

yup, my lvl is set as high. i just it’s just the way it is. 

What head/earphones are you using? Are they the same as you use on the others? If your volume is substantially less using the same phones, and you have it set ti HIGH as you say, it may just be a bum unit.

headphones are just some walmart crap. but my car is a plug in and on my old piece I had pretty decent audio… with this player it;'s not as much.  nothing much I can use I guess.

plus yesterday… when I plugged my player in my pc… it crashed my pc.  what heck… not sure. so charging though my ps3 now.  i gotta upda the player in few days… hope no issues at that time :X